PN5190 ULPCD (custom board)

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

PN5190 ULPCD (custom board)

736 Views
jr_hernandez
Contributor II

Hello,

I am testing my new custom board with PN5190 integrated similarly to PNEV5190 (EVB).

It seems to work OK with the integrated DC-DC, I can use LPCD and read tags and all.

Now I am trying to setup the ULPCD, so I have connected VUP_TX to VBATPWR, and I get an error when trying to calibrate. I guess it might be the same error shown here but not sure how to overcome this programatically.

The raised error is as follows:

PN5190 Booted correctly
-DEBUG-: [Thu Jan  1 00:00:00 1970] phDriver_PinConfig ( 34 )
-DEBUG-: [Thu Jan  1 00:00:00 1970] Install gpio isr service for gpio ( 34 )
-DEBUG-: [Thu Jan  1 00:00:00 1970] MIFARE key update...
-DEBUG-: [Thu Jan  1 00:00:00 1970] NFC init as ULPCD

ULPCD => 2x
Calibration once     => x2 LPCD calib...
ULPCD_Calib...
ULPCD_Get_HFATT_Value...
bHFATT_Val (0x11)
phhalHw_Lpcd...calibrating...

Line: 330   Error - (0x027F) has occurred : 0xCCEE CC-Component ID, EE-Error code. Refer-ph_Status.h

ULPCD Calibration Failed. Line: 588   Error - (0x027F) has occurred : 0xCCEE CC-Component ID, EE-Error code. Refer-ph_Status.h
NFC Calib error !

As you can see the HF attenuator value is read (bHFATT_Val (0x11)) during calibration.

VDD_BOOST remains connected to VUP_TX, so it is the same as the EVB.

Can anyone help on this?

Regards ,Ramon.

 

 

Labels (2)
Tags (1)
0 Kudos
Reply
1 Reply

664 Views
renkebienert
NXP Employee
NXP Employee

Hi Ramon,

I think we debugged this down to the x-tall issue, which might be starting too slow...

All the rest shall be working .

BR,

Renke

0 Kudos
Reply