KDS V2.0.0 and KSDK_1.1.0 with MQX

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

KDS V2.0.0 and KSDK_1.1.0 with MQX

2,018 Views
onurb
Contributor I

Hi,

Can someone help me

I have a problem with the FRDMK64F and my application.

The board  works properly with other applications.

The proble is that after a short time the application is interrupted

In the debug window, the following is displayed.

WDOG_EWM_IRQHandler () at startup_MK64F12.S: 362 0x568

<signal handler called> () at 0xfffffffd

_sched_start_internal () at dispatch.S: 94 0x56e

_mqx () at mqx.c: 812 0x736a

How can i disablen WDOG_EWM_IRQ ?

Bruno

0 Kudos
6 Replies

870 Views
soledad
NXP Employee
NXP Employee

Please check the below thread:

https://community.freescale.com/thread/353118#511192


Have a great day,
Sol

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos

870 Views
dave408
Senior Contributor II

Hi onurb​, did you get this issue resolved?  I just experienced the same thing.  I'm looking around to see what possible solutions are out there for me to try on my application.  Thanks!

0 Kudos

870 Views
mike_susen
NXP Employee
NXP Employee

Hi All,

I have same problem on K40. Did anybody resolved this issue?

Thanks

Michal

0 Kudos

870 Views
soledad
NXP Employee
NXP Employee

Hello vedana bruno,

Could you please share your application in order to reproduce your issue???

Regards

Soledad

0 Kudos

870 Views
auralcircuitry
Contributor II

I'm also seeing the exact same issue, glad I'm not the only one actually since it doesn't come up on the forum.

Essentially I followed this guide to building a framework MQX project: How To: Create a New MQX RTOS for KSDK Project in KDS

Something must be configured incorrectly in the linker or startup code.

If I load the same code from the pre-built example project (rtos hello world), it works fine.  If I try to build my own project from scratch by following these instructions (which I will need to do with a custom board) I run into this issue that appears to be the WDOG_EWM_IRQHandler being called and causing a DefaultISR interrup , even though if you look at the board files the DISABLE_WDOG code appears to be set correctly.

Here is the stack trace which happens just a few ms after startup:

pastedImage_1.png

I've tried creating an explicit handler for this (which doesn't fire), I don't know what else to do.  I'm new to the quirks of MQX but I don't know how to make a project that is any simpler and it's already showing issues.

Appreciate any help you can give here, thanks.

0 Kudos

870 Views
onurb
Contributor I

Hello Soledad

Since the project.

Regards

Bruno

0 Kudos