Can't delete terminated debug sessions

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't delete terminated debug sessions

83 Views
Contributor II

I copied/reloaded a couple of projects coming from MCUXpresso 10 into a new MCUXpresso 11.1.1 workspace, but every time I launch debugger looks like it can't be properly terminated. After that, the only way to start a new debug session is by restarting the IDE!

The "Remove all terminated launches" selections are disabled or without effect, and trying simply relaunching yields an error, as in picture

2020-05-29 19_15_07-src_main.c - MCUXpresso IDE.png

I tried importing the project in a new workspace, but had the same result.

Could be something related to JLink interface?

Note: target device is LPC17xx

2 Replies

6 Views
Contributor III

The same for me on Linux. I've found a workaround! right click on top debug level session and choose "Terminate and Remove".

6 Views
Contributor II

Thanks alexeym!

That resolved, and it did even more. I launched debug and choose "Terminate and Remove", everything was shut down properly. Moreover, on successive launches it was always terminated correctly!

Looks like one of the runs have left remnants which prevented the project to terminate clean; the "Terminate and Remove" however did the proper clean, and even restarting the IDE termination kept being done properly every time. Great.

Note: I'm running it on Windows, so no OS dependent, more about an unclean state left in debug configuration...

Luca

0 Kudos