ZPS_XS_E_NO_FREE_APS_ACK、ZPS_APL_APS_E_ILLEGAL_REQUEST

cancel
Showing results for 
Search instead for 
Did you mean: 

ZPS_XS_E_NO_FREE_APS_ACK、ZPS_APL_APS_E_ILLEGAL_REQUEST

208 Views
760167358
Contributor II

Question

    There are 9 end devices that join the network created by coordinator. The log file of coordinator has the error messages. The error messages are "ERROR: Extended status 0x83" and  "DT: AckDataReq not successful. Return: 0xa3". For details, see as below:

pastedImage_2.png

 pastedImage_4.png

    The error message indicates that the resource is used up. Is there any way to increase resources? Such as, modifying macro definition.

pastedImage_3.png

Environment

    The chip that I use is MKW41Z512.The IDE is MCUXpress IDE.For details, see as below:

pastedImage_7.png

pastedImage_6.png

 

topology

      Star network, 1 Coordinator / 9 End Devices (no router).

 

Remarks

    What conditions lead to this error? How should I solve the problems?

4 Replies

83 Views
760167358
Contributor II

The log file of end device has the error messages. The error messages are "ERROR: Extended status 0x89" and  "DT: AckDataReq not successful. Return: 0xa6". For details, see as below:

pastedImage_1.png

What conditions lead to this error? How should I solve the problems?

0 Kudos

83 Views
mario_castaneda
NXP TechSupport
NXP TechSupport

Hi,

ZPS_XS_E_BAD_PARAM_APSDE_REQ_RSP, // 0x89 A bad parameter has been found while processing an APSDE request or response.

I am not sure if you modify something in your code.

Then the Error that you are seeing.

 ZPS_XS_E_NO_FREE_APS_ACK,                // 0x83 There are no free APS acknowledgement handles.  The number of handles is set in the "Maximum Number of Simultaneous Data Requests with Acks" field of the "APS layer configuration" section of the config editor

Please increment the next define for the Maximum Number of Simultaneous Data Requests with Acks

/*! APSDE dcfm record pool size*/
#define APS_DCFM_RECORD_POOL_SIZE 5

Regards,

Mario

83 Views
760167358
Contributor II

The error "ZPS_XS_E_NO_FREE_APS_ACK" has been solved. But the another still exist.For details, see as below:

pastedImage_1.png

pastedImage_2.png

The error "ZPS_APL_APS_E_INVALID_PARAMETER" and "ZPS_XS_E_BAD_PARAM_APSDE_REQ_RSP" come together.As you see the log,

pastedImage_3.png

You can get in touch with the source code. From the source code, I believe that You will know what would lead to this error. The Zigbee 3.0 Stack of NXP is not a open source. NXP just provides some API interfaces.I have already read <Zigbee 3.0 Stack User Guide>. From document, I have already known the definition of error codes, but I have still not known that What conditions lead to this error.Because of that, I really need your help. 

0 Kudos

83 Views
mario_castaneda
NXP TechSupport
NXP TechSupport

Hi,

What is the specific example that you are working on?

Did you make some modifications to the code?

I will run some tests, and I will get back to you.

Regards,

Mario

0 Kudos