Component peripheral instances not showing in MCUXpresso config tool

cancel
Showing results for 
Search instead for 
Did you mean: 

Component peripheral instances not showing in MCUXpresso config tool

Jump to solution
167 Views
jasonlambert
Contributor II

My current set up is:

MCUXpresso:  v11.3.0 [Build 5222] [2021-01-11]

SDK: SDK_2.x_EVKB-IMXRT1050 version 2.9.1 

 

Not sure what i'm missing here. I'm walking thought the "Basic Application Development Using MCUXpresso IDE and MCUXpresso Config Tools" and Looking at the 3rd example. 

When they click the add button on the middleware icon of the components tab a USB instance shows up in the middle layer group. Then there is a USB1 instance window that is created that lets you configure the instance. 

When I do these exact steps the USB instance does not show up under the Middleware group in the components view. The configuration instance is still created. 

This behavior is being reflected when I try to add Peripheral drivers and Utilities. This causes an issue because you can not remove extra instances of the peripheral once you click the add. This ends up causing error in the code and un wanted components. 

 

usberror.PNG

0 Kudos
1 Solution
151 Views
jingpan
NXP TechSupport
NXP TechSupport

Hi jasonlambert,

This is so strange. You can try to delete  two folder in MCUXpresso workspace and restart the IDE. 

jingpan_0-1614850671988.png

If that is not work, there is a standalone config tool. You can try that tool.

 

Regards,

Jing

View solution in original post

3 Replies
135 Views
jasonlambert
Contributor II

That seems to have worked however the side affect is that every project was pushed out of my workspace. I guess I can go back and simple re-import them.

0 Kudos
120 Views
Petr_H
NXP Employee
NXP Employee

Yes, it seems that your workspace has been damaged and deleting removed all information so you now have to re-import projects back. Or maybe even safer would be to create a new workspace folder and re-import it there.  Anyway, I also recommend  to backup all your projects to some other folder. 

If you encounter some issues in the future or just want to return to default state of the views, I recommend to try the command Window > Perspective... > Reset Perspective that should help in such cases.  

Anyway, I hope that the issue is resolved a and you can continue working on your projects. 

Regards

Petr Hradsky

152 Views
jingpan
NXP TechSupport
NXP TechSupport

Hi jasonlambert,

This is so strange. You can try to delete  two folder in MCUXpresso workspace and restart the IDE. 

jingpan_0-1614850671988.png

If that is not work, there is a standalone config tool. You can try that tool.

 

Regards,

Jing

View solution in original post