How to flash LPC55S69-EVK board in ISP mode?

cancel
Showing results for 
Search instead for 
Did you mean: 

How to flash LPC55S69-EVK board in ISP mode?

353 Views
sergey_shidlovs
Contributor II

Hi!

I was trying to resolve another issue with an audio example but during experiments, my development board switched to non-working state:
- I can't upload and debug any app via SEGGER Ozone debugger (it says "No valid application in flash: Wait until bootloader is done.", then loses connection with the board;
- I can't upload and debug via J-Link GDB Server and host GDB client;
- can't do nothing with FlashMagic tool (It detects my board as LPC1768 device. I change it to LPC55 and try to start the process, but the app says "Operation failed. Failed to autobaud."). It seems I need to check the link mentioned there.

I think the issue can be caused by the J-Flash Lite tool that I tried to use to flash the precompiled example app on the board.

I also have tried to short J10 jumper and press reset, but nothing has changed.

Thanks in advance for helping.

Labels (3)
Tags (2)
0 Kudos
1 Reply

300 Views
ZhangJennie
NXP TechSupport
NXP TechSupport

Hi

You can't connect your LPCXpresso55s69  board.

You could try below:

1 update the on board debug firmware with LPCScrypt. try CMSIS-DAP as well.

pastedImage_1.png

2. use MCUXpresso IDE connect board in ISP mode, do mass erase.  then connect board again.

0 Kudos