Flash a LPC5410x with mxli

cancel
Showing results for 
Search instead for 
Did you mean: 

Flash a LPC5410x with mxli

87 Views
tlint
Contributor I

Hello dear NXP community, I would like to flash a bootloader on a LPC5410x with the mxli-3.3 tool from marc. The processor is recognised with the command ./mxli -n and output in the command line.

When trying to load a hex file onto the board, the error: Segmentation fault. I have read that errors can occur with hex files. So I tried to load a binary file. With the windows tool flash magic the loading worked without problems.

I tried to display some error causes with the following command:

./mxli -q -d/dev/ttyUSB0 -b115200 -c12M -g -v -k -i -x -E -T 10000 -p -G 3 LCS_Bootloader_Release.bin

The first partitions of the RAM were also successfully written:

Download to RAM [4096@0x02000000...

Download to RAM [4096@0x02001000...

Download to RAM [4096@0x02002000...

However, with RAM [4096@0x02003000... the errors came up:

ERROR: Data expected from LPC

ERROR: binary echo mismatch.

ERROR: write FLASH failed

Could someone perhaps give me a push in the right direction with this problem, or help me to find out where the problem is? I am grateful for any answer and help

Labels (1)
Tags (1)
0 Kudos
1 Reply

68 Views
converse
Senior Contributor V

I suggest that you contact the author of the tool directly. You can find his email address from his website:

http://www.windscooting.com/softy/mxli.html

 

0 Kudos