TWR-KV58220M Debug Issue

cancel
Showing results for 
Search instead for 
Did you mean: 

TWR-KV58220M Debug Issue

265 Views
softwaretestsof
Contributor I

Hello,

I have a TWR-KV58220M board and i cant debug with J-link or PEmicro universal(via JTAG port).

I’ve tried to unlock it  by using MCUExpresso Gui flash tool(Resurrect locked Kinetis Device) and i succeed.Afterwards i still got a trouble with connection to MKV58.

Those are the messages of “Resurrect Kinetis Device via J-Link”

  • Checking MCU info...
  • Scanning for targets...
  • Executing flash action...
  • SEGGER J-Link Commander V6.32b (Compiled May  8 2018 18:26:51)
  • DLL version V6.32b, compiled May  8 2018 18:26:33
  • J-Link Command File read successfully.
  • Processing script file...
  • J-Link Commander will now exit on Error
  • J-Link connection not established yet but required for command.
  • Connecting to J-Link via USB...O.K.
  • Firmware: J-Link OpenSDA 2 compiled Oct 13 2015 12:10:56
  • Hardware version: V1.00
  • S/N: 621000000         
  • VTref=3.300V
  • Found SWD-DP with ID 0x5BA02477
  • Unlocking device...O.K.
  • Script processing completed.

When i look at the RESET_B pin of TWR-K58, i noticed that the RESET_B keep oscillating,i see a “square wave”  in every 100ms.

I pulled RESET_B pin to low and tried to program with J-link and PE Micro Universal but no success.

Finally,I tried to connect TWR-K58 by using J-Link Commander.See the attachment for outputs.

J-Link Firmware : J-Link OpenSDA 2 compiled Oct 13 2015 12:10:56

Hardware version:V1.00

How can i debug again this chip? What is the issue that i am facing?

Regards.

0 Kudos
1 Reply

174 Views
Robin_Shen
NXP TechSupport
NXP TechSupport

Hi Yazılım,

Considering that you have PEmicro universal, please try to use the P&E recovery utility mentioned in Bricking and Recovering FRDM-KL25Z Boards: Reset, SWD Clock and Low Power.

besides:

Have you check the on-board OpenSDA debugger? It may also affect the KV58.

Please check the state of your device by refer: DAPLink bootloader update.
If it's in corrupted state. Then you can recover the board by updating the debug interface firmware again.
If it's in bricked state. Then you can only recover the board by flashing a new bootloader with an external debug probe.

 

Here the TWR-KV58F220M is not in the list of table.
Considering that the OpenSDA versions of the FRDM-K22F and TWR-KV58F220M boards are both V2.1, customer can direct use the file of FRDM-K22F.

 

Best Regards,

Robin

 

-----------------------------------------------------------------------------------------------------------------------
Note: If this post answers your question, please click the Correct Answer button. Thank you!
-----------------------------------------------------------------------------------------------------------------------

0 Kudos