MQX Lite problem with MK22FN512VDC12

cancel
Showing results for 
Search instead for 
Did you mean: 

MQX Lite problem with MK22FN512VDC12

203 Views
NXP Employee
NXP Employee

In attempting to address the following, I've done

73096_73096.pngkds_problem.png

I'm getting a compile error in MQX1.h, which is generated by Processor Expert: "'INT_LPTMR0' undeclared here".  I've tracked this back to the settings under the "Manage allocated interrupts" tab in the MQX1 PE Inspector window (shown above).  The project is set to automatically manage allocated interrupts, and it chooses INT_LPTMR0 as the last interrupt.  But for some reason does not generate the required #define.  If I change the "Manage allocated interrupts" PE setting to "By User", and manually change the "Last allocated interrupt" to "INT_PORTA" (which is the next interrupt the list), rerun PE, and build, then it compiles OK.

Here's my KDS configuration:

73445_73445.pngkds_configuration.png

The project involved is one of the builds for the next Freescale Kinetis Sensor Fusion release.  My coworker (who has a slightly older KDS configuration than shown above) does not see the problem.  We don't like mysteries, especially those that our customers may inherit.  We would also like to not have a "one-off" solution for just the K22 project.

So the questions to be answered are:

  • Is the problem with my personal KDS installation?
  • has a problem been introduced with recent changes in PE and/or KDS?
  • what other bone headed thing have I done?

I've attached the project in case some kind person chooses to review this for us.

Thanks,

Mike

Original Attachment has been moved to: FSFK_K22F.zip

Labels (1)
1 Reply

44 Views
NXP Employee
NXP Employee

Hi Michael,

Maybe I'm a little late but the processor expert update you mention was released for KDS version 1.1, KDS 3.0.0 already comes with processor expert support for the MK22FN512xxx12 so there is no need to install this update. I have tested the project you uploaded on my KDS 3.0.0 without the processor expert update and it works correctly.

Hope it helps!

Best Regards,

Carlos Mendoza

Technical Support Engineer

0 Kudos