Kinetis Design Studio V2.0.0 available on the Web!

cancel
Showing results for 
Search instead for 
Did you mean: 

Kinetis Design Studio V2.0.0 available on the Web!

Kinetis Design Studio V2.0.0 available on the Web!

Greetings,

the new release of Kinetis Design Studio V2.0.0 has been released and is available on the web (http://www.freescale.com/kds).

 

V2.0.0 is a new full release, supporting Windows (7/8 (both 32 and 64bit) and Linux (64bit binaries for Ubuntu, RHE and CentOS) from the download tab:

Kinetis Design Studio Integrated Development |Freescale

16880_16880.pngKDS v2.0.0 download.png

(current description says 32bit for Linux, but it is really 64bit, this should be fixed soon).

 

What's new:

  • Support for 64bit Linux with 64bit binaries.
  • Improved NPW (New Project Wizard) which automatically creates debugger launch configurations for OpenOCD, P&E and Segger.
  • Automatic device filtering in the NPW.
  • Greatly improved Kinetis SDK support with automatically adding compiler include paths for new Kinetis SDK component and files.
  • Updated P&E and Segger debug connections
  • Built-in support for the upcoming Kinetis SDK v1.1 release
  • Updated Processor Expert (V10.4.2)
  • Many bug fixes and other improvements

Details in the Kinetis Design Studio V2.0.0 release notes (Documentation Tab).

As with the previous V1.1.0 release, new device support and Kinetis SDK support is added through the SDK Eclipse update, present in the Kinetis SDK. See the release notes for details.

 

There is no need to uninstall V1.1.1, as V2.0.0 can be installed in parallel, and projects are compatible. Moving to V2.0.0 is highly recommended for Linux users and anyone using the Kinetis SDK.

 

Best regards,

Erich Styger

Labels (1)
Attachments
Comments

Let's hope that the KSDK 1.1 will follow ASAP :smileywink: (and the KSDK-MQX too)

Regards

Giacomo

EDIT: and of course it doesn't work.

Installed KDS 2.0.0 (for win) in parallel with KDS 1.1.1

Added Eclipse Update for KSDK 1.0.0-GA.

Opene a project made with KDS 1.1.1.

PE gives errors over errors.

For Example:

Error in the inherited component settings (HAL)FirmwareI2C1/HALProcessor Expert Problem
ERROR: Retrieving SDK version failed, please check SDK source files consistency (C:\Users\jack\Dropbox\MBD\Progetti\TwingTec\Firmware\twing_workspace\Firmware/SDK\ksdk_manifest.xml not found or corrupted).FirmwareCpuProcessor Expert Problem
ERROR: Unknown SDK versionFirmwarePIT_500Processor Expert Problem

Works fine on my apps. I only tried 3 - K64F/KDS.

But, as I have mentioned before - the newer MQX_KSDK solved all my issues with the demos.

I made a 2nd workspace - just to assure that version 1.1.1 wouldn't clobber 2.0. Seems to have been a waste of time. Version 2.0 seems to be quite solid.

Erich - why not add the  -f Kinetis.cfg in the debugger? (Plus you had a { pause } thingy from another thread)...

Anyway, nice going to the whole team.

.

Hi Scott,

the -f thing is specific to OpenOCD, as it expects a configuration file. Yes, it would be possible to either hardcode it into the plugin or into OpenOCD, but that might not be a good thing. And it would divert from the 'standard' way to work with OpenOCD. Things are at least now better as the KDS v2.0.0 wizard adds that to the debugger settings.

Erich

And bytheway, it is really a lot faster if you switch to the SEGGER JLink  firmware/debugger (like 2 seconds to download the program instead of 30).

Best Regards

Giacomo

With KDS 1.1.1, if I set the flag -gdwarf-2 in the project settings I could open the .elf file in Freemaster and use it to connect to the FRDM-K64F to do some real-time debugging.

Now with the KDS 2.0.0 this isn't working anymore...or I'm doing something wrong?

I explain: Freemaster needs a dwarf2 debugging file in order to function correctly. Going to the Project Properties->C/C++ Build->Debugging and setting the Debug Format as Dwarf-2 doesn't work (freemaster says that the dwarf sectoin of the .elf is corrupted). I tried to add -gstrict-dwarf in "Other debugging flags" and also "-gdwarf-2 in the "Other compiler flags" for the C anc C++ compiler (also in the linker) but still error.

Any Ideas?

Thanks

Best Regards

Giacomo

Have you used the update from the KDS update site:

Freescale KDS Update Site - http://freescale.com/lgfiles/updates/Eclipse/KDS

It has the MQX awareness plugin.

Erich

Hi Giacomo,

I'm not aware of any changes in this domain, so I'm surprised that this does not work. I have started in internal request on this topic, so hopefully I know more soon.

Erich

Hi Giacomo,

there is a new version of FreeMaster (V1.4.3.6) on http://www.freescale.com/freemaster which supports DWARF v4.

This one should work with KDS, can you try it?

Thanks,

Erich

Hi !

What about KDS ver 2.0.0. for Linux 32 bit ?

Regards.

Adam

I installed KDS200 and latest componet expert with Low Power LLS

Tutorial: Using the FRDM-KL25Z as Low Power Board | MCU on Eclipse

and it worked.

I did have a lot of issues getting there - but somehow I think it was driver error.

One issue was I created the app.c in the ./ directory instead of the ./source - and then when I moved it with a drag-n-drop in the KDS200 interface, it didn't regenerate the make file.

Is there a manual way of regenerating the makefile?

Eventually I manually deleted the make files in the ./debug - and it regenerated on the next pass.

You can recreate the make file with 'clean', see No rule to make target | MCU on Eclipse

Hi Adam,

you really need 32bit binaries, then you have to use V1.1.1. Going forward, the KDS is for 64bit Linux systems.

Erich

Yes I thought the Projects->Clean should do something like that, but for me the overall result was still a stuck object in regenerated Debug\subdir.mk

Seems like KDS200 has  some stale data somewhere.

So to confirm - I have a workspace B022b with a project llsModeKds200

I created a file accidentally in \B022b\llsMode.c

and build it - which creates an entry in B022b\Debug\llsMode.d & .o  and an entry in file B022b\Debug\subdir.mk

I realize I've made a wrong entry - so in Project Explorer I pick the file up and drop it on directory Sources - where it moves.

Clean with: Select Project->Clean - click project llsModeKds200

It regenerates B022b\Debug\subdir.mk - but they still have  B022b\Debug\llsMode.d & .o and  B022b\Debug\subdir.mk has the references to llsMode.d & .o

So I exit out of KDS and restart it.

Then I Clean - it deletes the B022b\Debug\\llsMode.d & .o  but still has stale data in subdir.mk

So to force the files to be regenerated I delete the B022b\Debug\*mk - and then BuildAll and now its all healthy again.

Should I enter this as an "issue" (possibly a bug :smileyhappy: ) to be looked at by the KDS team? or did I miss a step.

Version history
Revision #:
1 of 1
Last update:
‎11-24-2014 01:44 AM
Updated by: