KDS Debug Configurations (OpenOCD, P&E, Segger)

cancel
Showing results for 
Search instead for 
Did you mean: 

KDS Debug Configurations (OpenOCD, P&E, Segger)

KDS Debug Configurations (OpenOCD, P&E, Segger)

NOTE: the screenshots below are for KDS V1.0.1-beta!

 

After creating a new debug configuration is simple:

Select either 'GDB OpenOCD Debugging', 'GDB PEMicro Interface Debugging' or 'GDB SEGGER J-Link Debugging' and use the 'new' button:

11396_11396.pngpastedImage_1.png

Verify the project and application settings:

11397_11397.pngpastedImage_6.png

 

After that, there are a few settings to be checked or set, depending on your connection.

 

OpenOCD with CMSIS-DAP

Make sure '-f kinetis.cfg' is specified as 'Other Options':

11398_11398.pngpastedImage_0.png

 

P&E with OpenSDA or Multilink

Select your Interface, Port and Device Name:

11395_11395.pngpastedImage_0.png

 

Segger J-Link

Make sure you use the correct device name (link to Segger web page (scroll there down!) lists all supported devices).

OpenSDAv1 and OpenSDAv2 is using SWD.

11393_11393.pngpastedImage_3.png

Disable SWO if not supported by your connection:

11394_11394.pngpastedImage_6.png

Labels (1)
Comments

thanks for a very helpful page! The setup options in KDS are different (more complex) than CW, and I was scratching my head regarding what to do with my j-link (segger).  Lifesaver once again Erich!

Please, give an example of setting a debug session for OpenOCD FTDI debug interface for K60

Hello! 

I get this error when trying to program the Hexiwear device with OpenOCD.

Error in final launch sequence
Failed to execute MI command:
-target-select remote localhost:3333
Error message from debugger back end:
localhost:3333:The system tried to join a drive to a directory on a joined drive.

Any idea on how to fix it?

Thanks

It would be helpful if you could post screenshots of your debug launch configuration settings.

It basically means the GDB client cannot connect to the OpenOCD server (see the same message for Segger J-Link: Fix for GDB and “The system tried to join a drive to a directory on a joined drive”).

Can you check that:

- openOCD binary is properly referenced in your settings (${openocd_path}/${openocd_executable})

- OpenOCD binary actually exists on that path

- Start OpenOCD locally is checked

- Your Hexiwear docking station has the properl OpenOCD/CMSIS-DAP firmware loaded

?

I hope this helps,

Erich

Hello!

Thanks for your quick response.

Heres an image of my debug configuration 

OpenOCD Debug Config.PNG

The OpenOCD .exe exists on that path.

My Hexiwear docking station has Switch 5, (OpenSDA pin) up and both Switches 3 and 4 up to target the KW40Z MCU. 

More information that could be helpfull; when i run the openocd.exe from the command line, i get the following text:

pastedImage_2.png

Thank you very much for your help

Jaime

Hi Jaime,

OpenOCD only supports a limited number of Kinetis devices, and if I'm not mistaken, the KW40 is not supported. I have not used it for the KW40 and used P&E and Segger instead. I can look into how to re-program the K20 on the docking station with the DAPLink bootloader, but for this you will need an external probe in any case.

Erich

In case this is helpful: here is how to reprogram the Hexiwear docking station bootloader and firmware: Reprogramming the Mikroelektronika Hexiwear Dockingstation | MCU on Eclipse 

I hope this helps,

Erich

I am using KDS 3.2.0 by selecting PnE as debug option on the FDRM-KE06Z board. I follow the steps above to configure the Debug configurations. But an error message keeps popping-up:

"Launching xxx_Debug_PnE' has encountered a problem.

Error in services launch sequence

Details>>

Error in services launch sequence
PEmicro GDB Launch Failure : Another GDB Server debug session is alreadyusing the same Server Port number. To run simultaneous debug sessions, please specify a unique Server Port and GDBMI Port in the Debug Configuration for each project. If another session is not running simultaneously, make sure that the pegdbserver_console and the arm-none-eabi-gdb processes have terminated.

May i know what's wrong with my PnE configuration on Server Port number? I just have a project file open and build in my project explorer for this time being?

Version history
Revision #:
1 of 1
Last update:
‎04-30-2014 05:52 AM
Updated by: