DSC56F8345 & CW10.2

cancel
Showing results for 
Search instead for 
Did you mean: 

DSC56F8345 & CW10.2

556 Views
Contributor IV

Has anyone else here used a 56F8345 with CW10.2? Successfully?

 

I'm asking because I'm having real problems getting anything to run. Here's what works / doesn't work:

1. CW7.3, USB Tap, WinXP VM, '8345 custom hardware. Works ok.

2. CW7.3, USB Tap, WinXP VM, '8367 Freescale EVM. Works ok.
3. CW10.2, USB Tap, Win7 x64, '8367 Freescale EVM. Works ok.

4. CW10.2, USB Tap, Win7 x64, '8345 custom hardware. Fails...

 

Failure:

When a basic blank processor expert project is created for the 8345, the debugger (USB Tap ONCE) attaches and it looks to be ok, until you stop, and then see it's locked up in CPU.c, initialising the PLL - well, trying to. It will just loop waiting for lock bit to be set which never happens. It doesn't happen because the PLL power down bit is set, and the PLL is not running. But, according to Freescale, and my service request in with them, the debugger is writing ok.

 

If I then add code to the main{} function, the project will either run erratically, or the debugger will refuse to connect.

 

Has anyone else seen this behaviour? Freescale don't have an 8345 dev board I can use, to eliminate our custom hardware. However, our custom hardware is working ok with CW7.3 with no problems, as stated above.

 

Tried:

USB drivers (Newer libwin drivers are available from sourceforge but this hasn't helped.)

Re-installing CW10.2 + updating to 1.0.0 service / update patch

Different machines (this happens on both XP and Win7 x64, professional and home premium)

CCS config changes to configure for USB Tap explicitly. Also verbose logging and output sent to Freescale.

Numerous new projects / CW settings / USB Tap speed / config settings.

 

None of the above has helped. Any help is appreciated...

Labels (1)
0 Kudos
2 Replies

148 Views
Contributor IV

Anybody?

CW7.3 with custom hardware works, CW10.2 with custom hardware doesn't. This is pointing pretty much to CW itself, although 10.2 works with eval kit. ('8367) Just got through a nice shiny 84789 tower kit and that works with CW10.2 as well - these are all on USB Tap by the way.

Anyone know any config tricks I can try? I've altered ccs.cfg (which didn't help) and tried altering the tcl file (anyone know what's going on here???) but, no luck. My SR is in progress with a hardware engineer apaperently, as above in the "Failure" section, looks like the PLL isn't being set up correctly. If anyone knows why that is, it'd help...

148 Views
NXP TechSupport
NXP TechSupport

Have you solved your problem that customer board can not work under the platform:CW10.2 plus Win7X64 OS? If you have not, I suggest you try to install the latest CodeWarrior for mcu version 10.5 and have a test.

from the phenomenon that the PLL can not clock, of course, it is a hardware issue. Because the MC56F8345 does not have internal crystal, you have to use external 8MHz crystal with a 1M ohm parallel resistor. the Crystal should be close to the chip. But you said that the DSC worked fine if customer used CW7.3 , it is strange.

If you still have problem, pls send the code even schematics to the Email address:

a2731c@freescale.com

i will review your code.

0 Kudos