Trouble installing CodeWarrior 11.4.0 on XUbuntu 18.04

Showing results for 
Search instead for 
Did you mean: 

Trouble installing CodeWarrior 11.4.0 on XUbuntu 18.04

Contributor II

I downloaded both the offline and online installers for the eval copies of CodeWarrior and attempted to install on an XUbuntu 18.04 VM running under VMware on Windows 10 x64.

I installed all the prerequisites listed in the README.txt file. When I run 
sudo ./  I get the following error:

sudo: unable to execute ./ Permission denied

The permissions for are 777 (RWX RWX RWX), so it's not a real permissions problem.

When I went to open in a text editor, I got messages about font encoding - "The document was not UTF-8 valid", (Invalid byte sequence in conversion input)

And it appears that there is a binary payload embedded in the shell script.

So then I tried sudo bash -x ./

But it fails after a while with the error ./ line 482: /....../disk1/ Permision denied

Where ...... above replaces the full path to my install location.

We have ordered a fully licensed copy of this software (with CW TAP probe), which is due here any time now. Am I going to get the same install errors when I attempt to install it instead of an eval copy?



0 Kudos
1 Reply

NXP Employee
NXP Employee

CodeWarrior CW4NET_v2019.01 installation scripts usually use the following folder for installation:


Check permission for this folder.

This script contains a binary part. This binary part is not UTF-8.


I have tested this CodeWarrior using Ubuntu 18 under VmWare.

Have a great day,
Pavel Chubakov


- If this post answers your question, please click the "Mark Correct" button. Thank you!


- We are following threads for 7 weeks after the last post, later replies are ignored
Please open a new thread and refer to the closed one, if you have a related question at a later point in time.

0 Kudos