AnsweredAssumed Answered

Adding own Cluster to a sleeping endpoint (0x1234)

Question asked by Matthew Wood on Aug 20, 2019
Latest reply on Aug 23, 2019 by Mario Ignacio Castaneda Lopez

Good afternoon all,

 

   Please coud somebody help me out. When i am adding my own cluster following the ZigBee 3.0: Adding Clusters

tutorial. When i get down to the part where i am adding into the bas_device.h and base_device.c files for some reason its not able to recognise the syntax like it does with the temperature measurement cluster. when i hold my mouse over the tsCLD_StrainMeasurement a window doent appear like it does with the temperature one. See picture below.

 

 

I have created an .h based on the temperature .h file  for my strain sensor and placed that in

JN-SW-4170/Components/ZCL/Clusters/MeasurementAndSensing/include and also created an .c file based on the temperature .c file and placed that in JN-SW-4170/Components/ZCL/Clusters/MeasurementAndSensing/source.

 

I have gone through the adding cluster tutorial a few times and still get the same result

 

Please can somebody help in me trying to understand what could be causing the problem.

 

Regards

 

Matthew

Outcomes