AnsweredAssumed Answered

OSJTAG debugger Hangup Issue

Question asked by Dhaval Shah on May 18, 2011
Latest reply on Jun 1, 2011 by Dhaval Shah

Hello,

 

I am using TWR-K60 board for code development and OSJTAG Debugger for debugging the code.I am using Keil IDE for software development.  I have a working version of code and I am adding more functionality to it. Under normal circumstances I can load and debug the code.

 

When I added few more functions to my file and tried to debug the code using OSJTAG, the IDE just gets hanged and I am not able to do anything except kill the IDE process. I tried to burn the same code to board flash and it runs just fine under normal running condition.

 

Secondly, if I add more functionality to the same file, I am again able to debug the code with the section of code (with which i was not able to debug) included.

 

If I disable the newly added code, I am again able to debug using OSJTAG. 

 

I see, my code is working just fine, but some how when I try to debug OSJTAG gets hanged (for Flash based or RAM based target project). 

 

I am at a situation where I am not able to debug my code anymore for further development.

 

Has anyone else experianced this? Is there any code size limit associated with OSJTAG? Is there a bug in OSJTAG? What I need to do/take care of to avoid this situation?

 

Warm Regards,

d2v0!

Outcomes