AnsweredAssumed Answered

Question about building a customized u-boot for the t1042d4rdb board?

Question asked by Jason Dejesus on Dec 5, 2019
Latest reply on Dec 19, 2019 by Yusuf Altıparmak

I want to make some modifications to uboot for a project I'm working on. But I keep running into errors when trying to build. To test bitbake, I ran a normal bitbake fsl-image-minimal. It worked the first time. So then I modified the recipe file u-boot-qoriq_2016.01.bb. I am trying to direct the bitbake to use my github instead so it uses my modified uboot. Here are the 2 cases I'm dealing with:

 

Case 1: I try to make SRC_URI the ssh line. I get the error:

ERROR: ExpansionError during parsing /opt/QorIQ-SDK-V2.0-20160527-yocto/sources/meta-freescale/recipes-bsp/u-boot/u-boot-qoriq_2016.01.bb: Failure expanding variable do_fetch[file-checksums], expression was ${@bb.fetch.get_checksum_file_list(d)} ${@get_lic_checksum_file_list(d)} which triggered exception MalformedUrl: The URL: 'git@github**********/u-boot.git;branch=master' is invalid and cannot be interpreted

 

Case 2: I make my repository public, and use the https line for SRC_URI. bitbake clear works now, but with fsl-minial I get the error:

ERROR: oe_runmake failed
ERROR: Function failed: do_compile (log file is located at /opt/QorIQ-SDK-V2.0-20160527-yocto/build_t1042d4rdb/tmp/work/t1042d4rdb-fsl-linux/u-boot-qoriq/2016.01+fslgit-r0/temp/log.do_compile.29973)
ERROR: Logfile of failure stored in: /opt/QorIQ-SDK-V2.0-20160527-yocto/build_t1042d4rdb/tmp/work/t1042d4rdb-fsl-linux/u-boot-qoriq/2016.01+fslgit-r0/temp/log.do_compile.29973

 

Note: I set up a public key with github for this.

 

When these didn't work I reverted the file to when it did work. But NOW it says the SRCREV or commit id doesn't exist. I've tried deleting the board_t1042d4rdb folder to fix this but no luck.

Outcomes