AnsweredAssumed Answered

MX8MM won't enter fastboot mode

Question asked by mike malgin on Jun 3, 2019
Latest reply on Nov 18, 2019 by pad jakkahalli

Hello, I'm using MX8M Mini EVK with Android 9, under Windows 10. *ADB works* fine but I have a real trouble getting into fastboot mode.  I researched hard in all NXP documents - "Android_User's_Guide.pdf", "Android_Quick_Start_Guide.pdf" and even followed iMX6 instructions on how to config fastboot. Nothing works though. 

 

1. Obviously, both "developer mode" as well as "OEM unlocked" option are enabled.

2. When I run "adb shell reboot bootloader" the board is being rebooted but all I see is a blanked screen and both "fastboot oem unlocked" nor "fastboot usb" command ever returns.

3. I have the latest Google USB driver installed (tried to add vendor ID from iMX6 documentations, didn't really work either)

4. It should be noted that I was able to flush the images through UUU (with a new NXP build android_p9.0.0_2.0.0-ga_image_8mmevk.tar.gz)  but even with this new build the board won't enter fastboot mode.

 

Is there any change that needs to take place in the "android_winusb.inf" or "adb_usb.ini" ?

 

One last note, once the EVK board is booted in attempt to get into fastboot, instead of seeing "EVK_8MM" the device is changed to "USB download gadget", no idea if that's normal?

 

I will appreciate any help!

 

Thanks, Mike

Outcomes