AnsweredAssumed Answered

running JLinkGDBServerCL on opensuse

Question asked by Mark Scovel on Dec 6, 2018
Latest reply on Dec 6, 2018 by Hui_Ma

We have a working K65/KDS_v3/KSDK app that we can debug well under windows/jlink.

 

We moved it to Opensuse Tumbleweed 64 bit (our deployed boards require this environment) and can build but cannot debug.

 

When we launch a debug session, KDS says:

    "Could not determine GDB version after sending: arm-none-eabi-gdb --version, response: "

 

 

It looks like KDS has no idea it is supposed to execute ${jlink_path}/${jlink_gdbserver}. 

 

We have installed 64 bit arm toolchain as required for 64 bit systems and can build the .elf and convert to .hex and use jflash.exe to flash the board which runs fine.

 

We can manually run /opt/Freescale/KDS_v3/segger/JLinkGDBServerCL -device MK65FN2M0xxx18 -localhostonly and it connects to the board and displays the splash below.

 

Why is KDS issuing the wrong debug commands? How do we change it to use the right command? We tried changing the J-Link GDB Server Setup to run /opt/Freescale/KDS_v3/segger/JLinkGDBServerCL but we get the same result (error message above).

 

 

sudo ./JLinkGDBServerCL -device MK65FN2M0xxx18 -localhostonly
SEGGER J-Link GDB Server V5.10n Command Line Version

JLinkARM.dll V5.10n (DLL compiled Feb 19 2016 18:45:10)

-----GDB Server start settings-----
GDBInit file: none
GDB Server Listening port: 2331
SWO raw output listening port: 2332
Terminal I/O port: 2333
Accept remote connection: localhost only
Generate logfile: off
Verify download: off
Init regs on start: off
Silent mode: off
Single run mode: off
Target connection timeout: 0 ms
------J-Link related settings------
J-Link Host interface: USB
J-Link script: none
J-Link settings file: none
------Target related settings------
Target device: MK65FN2M0xxx18
Target interface: JTAG
Target interface speed: 1000kHz
Target endian: little

Connecting to J-Link...
J-Link is connected.

Outcomes