AnsweredAssumed Answered

FRDM-K66F Bricked on Windows10

Question asked by E F on Nov 16, 2018
Latest reply on Nov 20, 2018 by Robin_Shen

I am not new to microcontrollers, but very new to mbed controllers - new as in, blinky_led sample code bricked my controller 10 minutes after plugging it in for the first time.

 

For a few minutes, after loading blinky_led and trying to move to the next example, I was stuck with the controller mounting and showing up as bootloader.  It would periodically reboot and remount every minute or so.  So I tried updating the firmware by dragging-and-dropping the .bin file from  FRDM-K66F | Mbed .  Now the board doesn't even light up when plugged into USB and Windows doesn't recognize any device being plugged in.  If I plug into the power port, blinky_led will run.

 

I have a second board but I'm afraid to use it.  I plugged it in hoping that I could use it to install the Windows ARM serial driver, as I was receiving "no microcontroller found" with the bricked one - nope still get error despite this being the very first instruction on the aforementioned mbed website.  So I tried to do this right, and held down reset to go into bootloader mode, and at the beginning of a remounting cycle, tried to copy over the firmware.  NOPE!  firmware is 95kB and I only have 92kB of freespace on the board!  Also, the article says DAPLink needs to be upgraded if it mounts as "bootloader" - ok, but of course, there is no FRDM-K66F listed in the table: DAPLink bootloader update | Mbed  .  I would use the K64F, but its such a fragile piece of equipment, that I'm afraid to.

 

None of the instructions to keep this delicate thing from dying seem to work.  My second board is now stuck in bootloader mode, probably soon to be bricked as well.  Please help.  I want to use this board, but I'm frustrated by how out-of-the-box instructions don't work and can actually kill the board.  I haven't even tried anything unique yet.

 

EDIT:

Got board #2 working ok.  For some reason I showed 98kB of free space when loaded into Linux and could copy the firmware, which made the device appear as a drive called FRDM-K66FD.  And then the serial driver would install correctly.  I'm still stuck short of having a probe to allow debugging.  I checked my downloads, I believe I dropped blinkyled.bin onto the BootLoader drive which killed the first board - I did not drop firmware.  Hopefully there is a repair for this mistake.

Outcomes