AnsweredAssumed Answered

Getting an HDMI output on IMX8QMLPDDR4ARM2

Question asked by Mathias Faro on Mar 1, 2018
Latest reply on Apr 26, 2018 by Mathias Faro

Hi,

I just received my i.MX8 QM (LPD4CPU according to the packing list).

I set up my yocto environment as mentionned in the user guide with the repo command :

repo init -u https://source.codeaurora.org/external/imx/imx-manifest -b imx-linux-morty -m imx-4.9.51-8qm_beta2.xml

I built an image with yocto setting the correct machine, and wayland as a distro :

DISTRO=fsl-imx-wayland MACHINE=imx8qmlpddr4arm2 source fsl-setup-release.sh -b build

 

Then I ran a "bitbake fsl-image-qt5-validation-imx" and flash my SD card to boot on.

I connected my computer to the serial port and uses minicomto comunicate.

I also connected a screen (iiyama prolite b2280hs) through HDMI to the imx8 and expected to see the boot screen and then the GUI.

 

But when I boot the card, I have all the information about the boot that are displayed on the console (with the serial port) but nothing on the HDMI. When the boot end, I am connected to the console through the serial port, but still nothing on the HDMI.

 

I tried to setup the uboot environment for a 1080p60FPS screen, like it was mentionned here : Getting a 4K HDMI output on MCIMX8M-EVK , but it does not work either.

setenv mmcargs 'setenv bootargs console=${console} root=${mmcroot} video=HDMI-A-1:1920x1080-32@60'

 

I'm not sure if the problem comes from the monitor I use, or from the board itself. I tried to change several times the uboot environment to enable the HDMI and set up the display but without any success.

If anyone as encountered this problem, it would be great to discuss about it.

 

Best Regards,

Mathias

 



Outcomes