AnsweredAssumed Answered

iMX7s + M4 startup problems

Question asked by Ernesto Terribile on Oct 4, 2016
Latest reply on Oct 5, 2016 by Ernesto Terribile

Hi everyone.

I hope this is not a FAQ, I swear I tried to search around before writing this.

 

Here's my problem:
I have a colibri imx7s (a7 single core + m4) that I need to use in a project.

I am able to flash a root filesystem (ubifs), compile and flash a kernel (with and without modules, the final form will be without), and to build, flash and run an M4 program with FreeRTOS.

 

The problem is that if I run just Linux (4.1.15-v2.6b2), it works fine.

If I run just the M4 software (with debug on UART-B), it works fine.

If I try to run them both, problems start.

Following some guides, I put the uart-b in the fdt_fixup variable of uboot, as well as the ECSPI 1 and 3 that are used in the M4 software. Since then linux stopped giving me kernel panic, but it arrives to to i2c (or slightly after it) and just stops with the M4 still running.

 

I tried to remove the i2c (as well as rtc and ps/2) support from the kernel, or adding i2c to the fixup list, but nothing changes.

Is there any debug that I can activate to understand better what's going on? (I don't have a debugger that can be attached to the processor)

 

Thanks in advance for any hint.

 

Ernesto

Outcomes