AnsweredAssumed Answered

Stuck with Default ISR

Question asked by Michael Koller on Jul 31, 2016
Latest reply on Aug 4, 2016 by Alice_Yang

Hey there!

 

For a couple of hours now I try to get a previously working project running again.

(I have switched the Debugger from OpenOCD to PEMicro, because the K64F was unresponsive and dropped a new .bin file into the bootloader, otherwise everything should be exactly the same.)

In my project I am using Uart, SPI and the low power timer, so far.

One driver example(uart non blocking), that I modified a bit and was ok before, works to an extent, not all of it (flow control).

I made a new project to see if that maybe works. I thought I had the solution, when I noticed I had forgotten to copy the fsl_uart_irq.c, fsl_dspi_irq.c and fsl_lptmr_irq.c file into the Sources folder. So I thought, thats why I was stuck at the default ISR during runtime. But that only solved the problem for the LPTMR and DSPI.

UART still doesn't work and I suspect I have forgotten to declare or include something.

 

Here are my includes:

"../Sources"

"/home/michael/MCU/KSDK_1.3.0/platform/drivers/src/uart"

"../Sources/Board"

"../Sources/Utilities"

"/home/michael/MCU/KSDK_1.3.0/platform/osa/inc"

"/home/michael/MCU/KSDK_1.3.0/platform/osa/src"

"/home/michael/MCU/KSDK_1.3.0/platform/drivers/inc"

"/home/michael/MCU/KSDK_1.3.0/platform/drivers/src"

"/home/michael/MCU/KSDK_1.3.0/platform/hal/inc"

"/home/michael/MCU/KSDK_1.3.0/platform/hal/src"

"/home/michael/MCU/KSDK_1.3.0/platform/system/inc"

"/home/michael/MCU/KSDK_1.3.0/platform/system/src"

"../Project_Settings/Startup_Code"

"../SDK/platform/CMSIS/Include"

"../SDK/platform/devices"

"../SDK/platform/devices/MK64F12/include"

"${PROJECT_KSDK_PATH}/platform/utilities/inc"

"${PROJECT_KSDK_PATH}/platform/utilities/src"

"${PROJECT_KSDK_PATH}/platform/drivers/src/lptmr"

"${PROJECT_KSDK_PATH}/platform/drivers/inc"

 

I also have the necessary files in the Sources/Board and Sources/Utilities folder. I have found 2 pdf files that describe how to set up a new project and I've followed them.

 

I think it is again a beginner mistake, and maybe someone here can see it!

 

Thanks for any help and information,

Michael

Outcomes