lpcware

LPCXpresso error programming

Discussion created by lpcware Employee on Jun 15, 2016
Latest reply on Jun 15, 2016 by lpcware
Content originally posted in LPCWare by teslabox on Sun Nov 27 07:49:20 MST 2011
Hello everyone,

I have been using an LPCXpresso program v3.6.2 [Build 279] [29/01/2011] for very long time and something happened wrong last time when I tried use it again. After building my program in C code, my LPCXpresso program shows an error window at very beginning of “Program Flash” action to the LPCXpresso LPC1769. The error consists of: “02: Failed on connect: Ee(02). Not connected to emulator.” I guess that it is something wrong with physical connection between programmer and microcontroller but it is impossible because it is an original one-part board consists of programmer and microcontroller. 

I connect my LPCXpresso board to the computer thru USB cabel which always worked but I also tried use other USB cables and there is no positive results of these changes. For tests I also use other LPCXpresso LPC1769 board (the second one which  I have) and the error still appears during “Program Flashing”.

For more tests I used my board with the LPC1768 (board calls EM-LPC1700, manufactured by embest co.) there is a JTAG 10-pin ARM connector (like on a

LPXXpresso board) and I connected this board to LPC-Link programmer thru my (DIY) 10-pin cabel, changed target from LPC1769 to LPC1768 and I did the same – pressed “Program Flash” button – the same again (the error). For extra more test I installed LPCXpresso program on three different computers (1 x Windows XP SP3, 2 x Widows 7), I activated them and I tried all those combinations of boards, microcontrollers and USB cables but the error didn’t disappear.

Now I don’t know what to do. If someone has or had this problem and solved it well, let me know the solution please. I will be very grateful for this.

Best regards,
Kuba

Outcomes