AnsweredAssumed Answered

RIoT Board JTAG connection with ARM-USB-TINY-H

Question asked by Timofey Komarov on Mar 3, 2016
Latest reply on May 29, 2016 by Vincent Siles

Hello, guys!

 

I've RIoT board with i.MX 6Solo CPU. This board has 10-pin JTAG. To debug it I'd like to use Olimex ARM-USB-TINY-H and Olimex ARM-JTAG-20-10 connector. When I run OpenOCD (v 0.9.0) I get the following message:

 

openocd -f interface/olimex-arm-usb-tiny-h.cfg -f target/imx6.cfg

Open On-Chip Debugger 0.9.0 (2016-03-04-00:25)

Licensed under GNU GPL v2

For bug reports, read

    http://openocd.org/doc/doxygen/bugs.html

Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.

Warn : imx6.sdma: nonstandard IR value

adapter speed: 1000 kHz

Info : clock speed 1000 kHz

Error: JTAG scan chain interrogation failed: all zeroes

Error: Check JTAG interface, timings, target power, etc.

Error: Trying to use configured scan chain anyway...

Error: imx6.dap: IR capture error; saw 0x00 not 0x01

Warn : Bypassing JTAG setup events due to errors

Warn : Invalid ACK 0 in JTAG-DP transaction

...

So, it seems not to connect at all.

 

Switching to FTDI driver doesn't help.

I'm not a specialist in JTAG (I am a software guy), so I can't solve the problem by myself. The connection seems to be OK, i've tried to change board, JTAG-adapter and 20-10 connector (I got a pair of each) - nothing helps. I don't see any error in pinout.

 

Can anyone help me? Any ideas?

 

Thanks in advance!

 

PS:

I've attached all the schematics files from Olimex and RIoTboard websites to save your time.

Outcomes