AnsweredAssumed Answered

i.MX6 Ultra Lite EK - WM8960 issue with amixer

Question asked by Shashank Kulkarni on Feb 9, 2016

Hi,

 

I am using i.MX6 Ultra Lite Evaluation Kit for evaluating this series of processors. I used the image with kernel version 3.14.38 from freescale's software resources. More specifically, the board boots from micro SD card.

 

I wanted to evaluate the sound functionality of the board and used amixer from the terminal for the same. The codec is detected correctly as WM8960. I simply enabled the headphone output and tried the speaker-test. It seems to work as I hear pink noise. Then I decided to test sine wave by using arguments --test sine --frequency 5000 and I hear the same pink noise. I confirmed that something is amiss when I tried aplay <local wav file> and heard the same pink noise.

 

I decided to examine the default driver settings closely by using amixer scontents. Based on the datasheet and this great post by a Mr. Jimmy Chan (WM8960 audio codec ), I could verify that most of the default settings should be able to play correctly from the headphone. I am unclear about a couple of things though:

 

1) The LD2LO and RD2RO switches - which simple mixer control closes these switches? My understanding is that the Left Output Mixer PCM and Right Output Mixer PCM are mapped to these switches respectively.

2) The Right and Left Boost Mixers are ON - what switches do these map to?

 

Attached is the log from amixer scontents command.

 

Please help me solve this issue. I will move to a C++ application that uses alsalib only after the amixer-aplay-speaker-test works properly.

Thanks!

 

Regards,

Shashank

Original Attachment has been moved to: log.txt.zip

Outcomes