AnsweredAssumed Answered

p1011 how to config the endpoint (EP)

Question asked by yang yang on Nov 11, 2015

we have 2 p1011 board that we run vxworks on.

1. Now I'm trying to configure the PCIE2 of board A p1011 for the RC.

            I'm trying to configure the PCIE1 of board B p1011 for the EP(cfg_host_agt[0:2]=000,Device acts as an agent on all its PCI Express interfaces).

2. board A and board B are plugin the backboard.

3. when the backboard power on.

  1)the boardA RC: LTSSM shows Detect quie; no pcie device found.

  2)the boardB EP: 

    PCI_Bus @ 0x0038eea0 with bridge @ 0x003905a0

    Device Instances:

    Orphan Devices:

        (null) unit 0 on PCI_Bus @ 0x0039dba0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039dca0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039dda0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039dea0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039dfa0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e0a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e1a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e2a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e3a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e4a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e5a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e6a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e7a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e8a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039e9a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039eaa0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039eba0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039eca0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039eda0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039eea0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039efa0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039f0a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039f1a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039f2a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039f3a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039f4a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039f5a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x0039f6a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x003a07a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x003a08a0 with busInfo 0x00000000

        (null) unit 0 on PCI_Bus @ 0x003a09a0 with busInfo 0x00000000

 

4. when I put the boardA p1011 in the backboard, I put boardC(not p1011, a PCIE device) in the backboard, the backboard power on:

   1) boardA p1011: LTSSM shows L0, vxBusShow can found the boardC.

   so I think the configration of boardA p1011 RC is correct.

 

5 would you please give me some suggestion, how to config the EndPoint register of P1011?

Outcomes