Bobby Liniger

AN2295 Serial Bootloader error for 9S08GT60A

Discussion created by Bobby Liniger on Sep 24, 2007
Latest reply on Jan 20, 2009 by Sergio Acosta
When I run hc08sprg.exe it fails to program.  Please refer to the following jpg

After asking "Are you sure to program part? [y/N]:"  I respond with "y" enter
Then it responds "Memory programming: E 0x182C 0%"  It will sit here for over 2hrs, so I'm pretty sure the E is meaning some sort of error.  The AN2295.pdf is no help in this regard.  My code works when programmed over the BDM. 

I have three projects, the serial bootloader "hc08sprg-s08gbgt.mcp" and then my project "MSCA(M).mcp", and also an edited MSCA(M).mcp to include the serial bootloader "SerBootloader.mcp" 

The plain serial bootloader project, and combined project program the same and provide the same error when I run hc08sprg.exe

My code MSCA(M) and combined code both operate my user code properly.   

I am unable to program with the serial bootloader.  I'm using a USB to RS232 port, but that shouldn't be the problem since it establishes comunication properly.  I've even tried different *.s19 files thinking maybe mine was a problem, but that didn't change anything.

Also I am using SCI2 of the MCU



Message Edited by Risan on 2007-09-24 09:52 PM

SCIBootloader.JPG

Message Edited by t.dowe on 2009-09-03 05:41 PM

Outcomes