AnsweredAssumed Answered

Download size limit has been exceeded.

Question asked by Christoph Mayer on Jun 25, 2014
Latest reply on Jun 25, 2014 by Mark Butcher

Hi all

 

I am using the TWR-K64F120M with CodeWarrior v10.6 special and downloaded the MQX 4.1 for TWRK64F120M integrating in CodeWarrior and building worked fine. After some first tests using the LEDs I tried to include the rtcs in my project.
After fixing some linking errors I get a new Error this time from Freescale:

 

error_message.PNG.png

After some research I found out that this error could occur if the download size has been exceeded because it is limited in my version for Kinetis K64 to 128kB but since I am just testing to use the rtcs I do not think this is the case.

Furthermore my version does not support C++ so maybe there are some C++ files compiled. I found this article Please Check Your License | MCU on Eclipse the guy there had the same problem but I can not follow his solution my properties menu looks different.
And I didn't find out how to generate and where to find the linker map. Even the "Enable Exception" checkbox is not there, since there is no language tab.

 

Does anyone know how to solve this? Or how I can prove if the download size has been exceeded or if there are some C++ files...

 

Thanks a lot.

 

properties.PNG.png

Outcomes