AnsweredAssumed Answered

Problem about build the meta-toolchain-qte on newest release Yocto bsp

Question asked by brianwu on May 12, 2014
Latest reply on Dec 4, 2014 by Roger Houston

Hi,

I am not sure could I ask this question here?

I use the newest 3.10.17_GA Yocto bsp and try to bitbake the meta-toolchain-qte, but I got some errors.

 

Here is my command:

> MACHINE=imx6qsabresd source fsl-setup-release.sh –b build –e fb

> bitbake meta-toolchain-qte

 

Here is my error message:

user@user-N550JK:~/fsl-yocto/build$ bitbake meta-toolchain-qte

WARNING: Host distribution "Ubuntu-14.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution.

Loading cache: 100% |###########################################| ETA:  00:00:00

Loaded 2005 entries from dependency cache.

NOTE: Resolving any missing task queue dependencies

NOTE: multiple providers are available for jpeg (jpeg, libjpeg-turbo)

NOTE: consider defining a PREFERRED_PROVIDER entry to match jpeg

ERROR: Nothing PROVIDES 'nativesdk-libx11' (but /home/user/fsl-yocto/sources/poky/meta/recipes-qt/qt4/nativesdk-qt4-tools_4.8.5.bb DEPENDS on or otherwise requires it)

ERROR: nativesdk-libx11 was skipped: 'x11' not in DISTRO_FEATURES

NOTE: Runtime target 'nativesdk-qt4-tools' is unbuildable, removing...

Missing or unbuildable dependency chain was: ['nativesdk-qt4-tools', 'nativesdk-libx11']

NOTE: Runtime target 'nativesdk-packagegroup-qte-toolchain-host' is unbuildable, removing...

Missing or unbuildable dependency chain was: ['nativesdk-packagegroup-qte-toolchain-host', 'nativesdk-qt4-tools', 'nativesdk-libx11']

ERROR: Required build target 'meta-toolchain-qte' has no buildable providers.

Missing or unbuildable dependency chain was: ['meta-toolchain-qte', 'nativesdk-packagegroup-qte-toolchain-host', 'nativesdk-qt4-tools', 'nativesdk-libx11']

 

 

Does anyone have any information about this?

 

BR

Brian

Outcomes