AnsweredAssumed Answered

SWAP Flash ACCERR Error AN4533 on TWR-K60N512

Question asked by alfredogualdron on Feb 4, 2014
Latest reply on Feb 17, 2014 by Kan_Li

Hello, I'm trying to implement the flash swap function in one of my projects in order to be able to update the firmware remotely.

 

I read the AN4533 and I try to run the example software on my K60 tower.

I'm using codewarrior Version: 10.3 Build Id:121211, and TWR-K60N512 (700-26548 RevB)

and currently I'm using the P&EMicro Multilink USB device instead of OSJTAG.

 

The problem is when I run the swap_demo code it returns the folowing:

External Pin Reset

K60-144pin      Silicon rev 1.0 

Flash parameter version 0.0.0.0

Flash version ID 0.0.0.0

512 kBytes of P-flash P-flash only

128 kBytes of RAM

 

/********************************************************/

/*              Flash Block Swap Demo                   */

/********************************************************/

 

Program Flash Block 0 located at address 0x0000

Executing from Program Flash Block 0

Initializing Flash Driver: Success!

Checking Swap System Status: Failed!

Error: FTFx_ERR_ACCERR

 

 

I checked the register in the reference manual, but still not understand what is wrong.

I'm trying to debug the example code to figure out where the error occurs, it seems to be at FlashCommandSequence() function when executing pPFlashGetSwapStatus().

 

I'm pretty new in this feature and I do not have any idea of what is wrong, where I have to check or what can I do to solve the problem. I'm lost.

If you have any idea I will be happy to know...

 

thanks

Outcomes