AnsweredAssumed Answered

Try to use gstreamer and LTIB fails to build freescale specific libraries for SabreSD board

Question asked by Makis Livadas on Aug 6, 2013
Latest reply on Aug 9, 2013 by Makis Livadas

I tried to use gstreamer to view a video on the lcd display of a SabreSD board. I use

gst-launch playbin2 uri=....

But I get a message that a plugin is missing.

I discovered that I don't have the element mfw_v4lsink.

Tried to use LTIB to install gst-fsl-plugins but LTIB is not able to build. (./ltib --configure)

 

Here is what I am getting from the build

 

---------------------------------------------------------

Processing: gstreamer-core
============================

 

Processing: gst-plugins-base
==============================

 

Processing: gst-plugins-good
==============================

 

Processing: gst-plugins-bad
=============================

 

Processing: gst-plugins-ugly
==============================

 

Processing: gst-ffmpeg
========================

 

Processing: gst-plugins-farsight
==================================

 

Processing: xorg-x11-proto-devel
==================================

 

Processing: xorg-server
=========================

 

Processing: libXrandr
=======================

 

Processing: firmware-imx
==========================

 

Processing: imx-lib
=====================

 

Processing: imx-test
======================

 

Processing: kobs-ng
=====================

 

Processing: libfslcodec
=========================
Build path taken because: no prebuilt rpm,
Testing network connectivity
OK GPP:

 

Try libfslcodec-3.0.5.tar.gz.md5 from the GPP
http://bitshrine.org/gpp/libfslcodec-3.0.5.tar.gz.md5:
19:35:04 ERROR 404: Not Found.
Try libfslcodec-3.0.5.tar.gz from the GPP
http://bitshrine.org/gpp/libfslcodec-3.0.5.tar.gz:
19:35:04 ERROR 404: Not Found.
Can't get: libfslcodec-3.0.5.tar.gz at ./ltib line 802.

 


f_buildrpms() returned an error, exiting
traceback:
main:572

 


Started: Tue Aug  6 19:28:00 2013
Ended:   Tue Aug  6 19:35:04 2013
Elapsed: 424 seconds

 

These packages failed to build:
libfslcodec

 

Build Failed

 

-----------------------------------------------------

 

I using LTIB from the latest release of Linux for iMX6 from the freescale site.

 

Is this a known issue?

Do I need to build gst-fsl-plugins in a different way outside of LTIB main configuration tool (./ltib --configure)?

Outcomes