AnsweredAssumed Answered

iMX portrait mode

Question asked by Marius Octavian on Aug 4, 2013
Latest reply on Oct 13, 2013 by Luca Bassanello

Hello,

 

I am trying to go in Portrait mode with SABRE iMX6 and 'eGalax Touch Screen,

using Kernel 3.0.35-2508-g54750ff. and uboot u-boot-mx6q-sabresd.bin

 

The Option Rotate CCW in xorg.conf works only if I comment out the vivante driver.

I really need the vivante inplace, because the media play is acceptable. Without it is terrible.

 

1. Is there a workaround to rotate and keep vivante in place ?

 

Section "Device"
    Identifier    "i.MX Accelerated Framebuffer Device"
    Driver        "fbdev"
#    Driver        "vivante"
    Option        "fbdev"        "/dev/fb0"
#    Option        "vivante_fbdev"    "/dev/fb0"
    Option        "Rotate"    "CCW"
EndSection

 

Second is the evdev touch Axis swap option which does not work, even the

xinput --list-props 11 <cr> reports the swapping setting was committed.

 

Device 'eGalax Touch Screen':

    Device Enabled (114):    1

    Coordinate Transformation Matrix (115):    1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000

    Device Accel Profile (232):    0

    Device Accel Constant Deceleration (233):    1.000000

    Device Accel Adaptive Deceleration (234):    1.000000

    Device Accel Velocity Scaling (235):    10.000000

    Evdev Axis Inversion (236):    0, 0

    Evdev Axis Calibration (237):    31935, 284, 33626, 869

    Evdev Axes Swap (238):    1

 

 

Thank you.

Outcomes