AnsweredAssumed Answered

Xorg configuration for Linux kernel on iMX6Q SabreSD board

Question asked by Makis Livadas on Jul 19, 2013

I am trying to configure Xorg on my iMX6Q SabreSD evaluation with no success.

I have build linux kernel and Xorg7.5 packages with LTIB and kernel boots fine on the board.

When I type Xorg on the console terminal Xorg fails to start.

Is there any special procedure I should follow to get Xorg to run OK on thie board?

 

Below is the output of Xorg I am getting when I run it on the board.

 

root@freescale ~$ Xorg

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6

_XSERVTransOpen: transport open failed for inet6/freescale:0

_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

 

X.Org X Server 1.6.1

Release Date: 2009-4-14

X Protocol Version 11, Revision 0

Build Operating System: Linux 3.8.0-26-generic x86_64

Current Operating System: Linux freescale 3.0.35-2508-g54750ff-svn3 #3 SMP PREEMPT Fri Jul 19 16:24:28 BST 2013 armv7l

Build Date: 15 July 2013  04:04:13PM

 

        Before reporting problems, check http://wiki.x.org

        to make sure that you have the latest version.

Markers: (--) probed, (**) from config file, (==) default setting,

        (++) from command line, (!!) notice, (II) informational,

        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/usr/var/log/Xorg.0.log", Time: Thu Jan  1 00:35:07 1970

Primary device is not PCI

(==) Using default built-in configuration (12 lines)

(EE) Failed to load module "glx" (module does not exist, 0)

(EE) Failed to load module "dri" (module does not exist, 0)

(EE) Failed to load module "fbdev" (module does not exist, 0)

(EE) Failed to load module "mouse" (module does not exist, 0)

(EE) Failed to load module "kbd" (module does not exist, 0)

(EE) No drivers available.

 

Fatal server error:

no screens found

 

Please consult the The X.Org Foundation support

         at http://wiki.x.org

for help.

Please also check the log file at "/usr/var/log/Xorg.0.log" for additional information.

 

and the log file above is as follows:

 

_XSERVTransSocketOpenCOTSServer: Unable to open socket for inet6

_XSERVTransOpen: transport open failed for inet6/freescale:0

_XSERVTransMakeAllCOTSServerListeners: failed to open listener for inet6

 

X.Org X Server 1.6.1

Release Date: 2009-4-14

X Protocol Version 11, Revision 0

Build Operating System: Linux 3.8.0-26-generic x86_64

Current Operating System: Linux freescale 3.0.35-2508-g54750ff-svn3 #3 SMP PREEMPT Fri Jul 19 16:24:28 BST 2013 armv7l

Build Date: 15 July 2013  04:04:13PM

 

    Before reporting problems, check http://wiki.x.org

    to make sure that you have the latest version.

Markers: (--) probed, (**) from config file, (==) default setting,

    (++) from command line, (!!) notice, (II) informational,

    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.

(==) Log file: "/usr/var/log/Xorg.0.log", Time: Thu Jan  1 00:51:17 1970

(II) Loader magic: 0x5b0

(II) Module ABI versions:

    X.Org ANSI C Emulation: 0.4

    X.Org Video Driver: 5.0

    X.Org XInput driver : 4.0

    X.Org Server Extension : 2.0

(II) Loader running on linux

(--) using VT number 2

 

Primary device is not PCI

(==) Using default built-in configuration (12 lines)

(==) --- Start of built-in configuration ---

    Section "Device"

        Identifier    "Builtin Default fbdev Device 0"

        Driver    "fbdev"

    EndSection

    Section "Screen"

        Identifier    "Builtin Default fbdev Screen 0"

        Device    "Builtin Default fbdev Device 0"

    EndSection

    Section "ServerLayout"

        Identifier    "Builtin Default Layout"

        Screen    "Builtin Default fbdev Screen 0"

    EndSection

(==) --- End of built-in configuration ---

(==) ServerLayout "Builtin Default Layout"

(**) |-->Screen "Builtin Default fbdev Screen 0" (0)

(**) |   |-->Monitor "<default monitor>"

(**) |   |-->Device "Builtin Default fbdev Device 0"

(==) No monitor specified for screen "Builtin Default fbdev Screen 0".

    Using a default monitor configuration.

(==) Not automatically adding devices

(==) Not automatically enabling devices

(==) FontPath set to:

    built-ins

(==) ModulePath set to "/usr/lib/xorg/modules"

(==) |-->Input Device "<default pointer>"

(==) |-->Input Device "<default keyboard>"

(==) The core pointer device wasn't specified explicitly in the layout.

    Using the default mouse configuration.

(==) The core keyboard device wasn't specified explicitly in the layout.

    Using the default keyboard configuration.

(II) Open APM successful

(II) System resource ranges:

(II) LoadModule: "extmod"

(II) Loading /usr/lib/xorg/modules/extensions//libextmod.so

(II) Module extmod: vendor="X.Org Foundation"

    compiled for 1.6.1, module version = 1.0.0

    Module class: X.Org Server Extension

    ABI class: X.Org Server Extension, version 2.0

(II) Loading extension MIT-SCREEN-SAVER

(II) Loading extension XFree86-DGA

(II) Loading extension DPMS

(II) Loading extension XVideo

(II) Loading extension XVideo-MotionCompensation

(II) Loading extension X-Resource

(II) LoadModule: "dbe"

(II) Loading /usr/lib/xorg/modules/extensions//libdbe.so

(II) Module dbe: vendor="X.Org Foundation"

    compiled for 1.6.1, module version = 1.0.0

    Module class: X.Org Server Extension

    ABI class: X.Org Server Extension, version 2.0

(II) Loading extension DOUBLE-BUFFER

(II) LoadModule: "glx"

(WW) Warning, couldn't open module glx

(II) UnloadModule: "glx"

(EE) Failed to load module "glx" (module does not exist, 0)

(II) LoadModule: "dri"

(WW) Warning, couldn't open module dri

(II) UnloadModule: "dri"

(EE) Failed to load module "dri" (module does not exist, 0)

(II) LoadModule: "fbdev"

(WW) Warning, couldn't open module fbdev

(II) UnloadModule: "fbdev"

(EE) Failed to load module "fbdev" (module does not exist, 0)

(II) LoadModule: "mouse"

(WW) Warning, couldn't open module mouse

(II) UnloadModule: "mouse"

(EE) Failed to load module "mouse" (module does not exist, 0)

(II) LoadModule: "kbd"

(WW) Warning, couldn't open module kbd

(II) UnloadModule: "kbd"

(EE) Failed to load module "kbd" (module does not exist, 0)

(EE) No drivers available.

 

Fatal server error:

no screens found

 

Please consult the The X.Org Foundation support

     at http://wiki.x.org

for help.

Please also check the log file at "/usr/var/log/Xorg.0.log" for additional information.

 


Outcomes