Jean-Paul Le Pape

I have a wrong MAC address with my i.MX53 qsb

Discussion created by Jean-Paul Le Pape on Dec 22, 2011
Latest reply on Dec 22, 2011 by Jean-Paul Le Pape

Hello,

  I have a strange issue with the network connection.

I'm using the i.mx53 qsb. I'm using U-Boot version 2011.09 and I'm using the kernel 3.2.0-rc6. I build both of them myself.

 

When I boot the system (from a SD card that I formatted), I have U-Boot telling me that is got the Mac address from fuse. This is the exact message:

Net:   got MAC address from fuse: 00:04:9f:01:b3:5e 

 

On the following line, U-Boot tells me that it fails the set the Mac Address. Do anyone knows what is going on? The exact message displayed by U-Boot is the following:

FECWarning: failed to set MAC address

 

 

When I boot into Linux and run the command: ifconfig eth0

I have have this result:

 

eth0       Link encap:Ethernet  HWaddr 00:00:00:00:00:00

              BROADCAST MULTICAST  MTU:1500  Metric:1 

              RX packets:0 errors:0 dropped:0 overruns:0 frame:0

              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

              collisions:0 txqueuelen:1000

              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

 

 

 

As you can see, the MAC Address is 00:00:00:00:00:00 which is completely strange. So Do I need to set the MAC from U-Boot? If yes how do I do that? If the problem is not caused by U-Boot, it should be the kernel causing this issue. In the case that the problem is cause by the Kernel, do somebody knows which option should I activate in the kernel.

 

Thanks for your help. I Attached the output from U-Boot and the kernel.

:-)

Attachments

Outcomes