Iain Galloway

LTIB install failure using Debian/Ubuntu Edgy Eft

Discussion created by Iain Galloway on Nov 22, 2006
Latest reply on Jul 1, 2010 by Cristian Stoica
I'm still looking into this problem, but thought I'd report it in case someone can assist, or maybe it can help someone else in the future:

Refernce point
-New Ubuntu Edgy Eft install
-Installed build-essentials package
-Installed anything that related to rpm using Synaptic (apt-get)
-Tried both the rpm and CVS of LTIB

When I first run ./ltib to do the initial install I get the following:

Processing platform: host support
===================================
(see logfile: /home/test/dvl/ltib/host_config.log)
using

Processing: rpm-fs
====================
symlink /tmp/rpm-4.0.4.tar.gz, /tmp/rpm-test/SOURCES/rpm-4.0.4.tar.gz: No such file or directory

Started: Wed Nov 22 11:48:32 2006
Ended: Wed Nov 22 11:48:32 2006
Elapsed: 0 seconds

Build Failed


The file /tmp/rpm-4.0.4.tar.gz exists, but /tmp/rpm-test/SOURCES/rpm-4.0.4.tar.gz doesn't.
I'll continue trying a few things...

---ok, look at this...

test@iain-laptop:~/dvl/ltib$ ls -l /tmp/rpm-4.0.4.tar.gz
-rwxrwxrwx 1 iain iain 5886675 2006-01-26 11:09 /tmp/rpm-4.0.4.tar.gz

test@iain-laptop:~/dvl/ltib$ ls /tmp/rpm-test/SOURCES/rpm-4.0.4.tar.gz
ls: /tmp/rpm-test/SOURCES/rpm-4.0.4.tar.gz: No such file or directory

test@iain-laptop:~/dvl/ltib$ cp /tmp/rpm-4.0.4.tar.gz /tmp/rpm-test/SOURCES/rpm-4.0.4.tar.gz
cp: cannot create regular file `/tmp/rpm-test/SOURCES/rpm-4.0.4.tar.gz': No such file or directory

test@iain-laptop:~/dvl/ltib$ mkdir /tmp/rpm-test/SOURCES

test@iain-laptop:~/dvl/ltib$ cp /tmp/rpm-4.0.4.tar.gz /tmp/rpm-test/SOURCES/rpm-4.0.4.tar.gz

----
So the "SOURCES" directory didn't appear to exist, although there is a directory with "{..}" in it. See Below...

iain@iain-laptop:~/dvl/uClinux-2.0.x/mm$ ls -l /tmp/rpm-test/
total 16
drwxr-xr-x 2 test test 4096 2006-11-22 12:08 {BUILD,RPMS,SOURCES,SPECS,SRPMS}
drwxr-xr-x 2 test test 4096 2006-11-22 11:12 rootfs
drwxr-xr-x 2 test test 4096 2006-11-22 11:12 rpmdb
drwxr-xr-x 2 test test 4096 2006-11-22 12:13 SOURCES

iain@iain-laptop:~/dvl/uClinux-2.0.x/mm$ ls -l /tmp/rpm-test/SPECS
ls: /tmp/rpm-test/SPECS: No such file or directory

---
But as you can see, I can't browse to the SPECS directory.
I'm not familiar with this {} naming convention...which I'm assuming is supposed to be a "set" of directories? and then again maybe this doesn't really exist, and it's just an error in ltib or a script?

(FYI - After manually adding the /tmp/rpm-test/SOURCES directory, the ltib install went past that point and failed again when referring to the /tmprpm-test/BUILD directory.
I'm just going to manually create these directories and go from there...)

Outcomes