map network drive

Showing results for 
Search instead for 
Did you mean: 

map network drive

Contributor III

hello everyone,

i have an issue while trying to map a network drive using the qsb.

my configuration is:

i compiled uboot,kernel and fs using ltib and installed samba (checked the start smbd nmbd).

i created a smb.conf file in /usr/lib as i understood from some manual.

the qsb is connecting to a laptop with eth.

everything is working well untill now.

i succeded to map a sata drive connected to the qsb in the connected pc running win7 and accessed the files.

now i'm trien to do the oposite action. i'm trying to share a folder from windows and access it from the qsb.

i've tried using the command: mount -t cifs //x.x.x.x/sharename but i'm keep getting error says: "mount: mounting //x.x.x.x/Maps on /mnt/win failed: No such device"


* the x.x.x.x is the windows machine ip number that i change here to x.x.x.x.


i also tried running that command on the linux host pc that i have ltib on but that finished succesfully, so something is wrong with the configuration on the qsb...


did anyone had this problem or have an idea?




Labels (1)
2 Replies

Contributor III

well problem solved... just forgot to check network filesystems in kernel build... for cifs and smbfs...

Contributor III

i tried running smbclient -L x.x.x.x and got all shares, i can see the folder i'm triend to mount but i also get this lines in the end:

session request to x.x.x.x failed (Called name not present)

 session request to 10 failed (Called name not present)

session request to *SMBSERVER failed (Called name not present)

NetBIOS over TCP disabled -- no workgroup available


(again the x.x.x.x is the ipnuber that i changed to that after pasting here)


hope that will help someone to point the problem for me.




0 Kudos