failed to set up Yocto environment in Ubuntu16.04

cancel
Showing results for 
Search instead for 
Did you mean: 

failed to set up Yocto environment in Ubuntu16.04

1,141 Views
djoygaurav
Contributor II

Hi there,

 

Actually I had been trying to setup Yocto on my Ubuntu 16.04LTS distribution for i.mx6qsabresd board(and later will be doing same for T4240), and I am working in a proxy environment. I successfully fetched layers and the Image also started building($bitbake core-image-minimal) but I got some multiple errors for which I am not finding solution. First of all, I got a warning saying "WARNING: Host distribution "Ubuntu-16.04" has not been validated with this version of the build system; you may possibly experience unexpected failures. It is recommended that you use a tested distribution." and then there were errors for elfutils and glib. I am attaching log for your reference. I am new on Yocto so kindly provide reference also to help me understand what I am supposed to do. Any kind of help is appreciated.

Thank You in advance!

 

Gaurav Kumar

Original Attachment has been moved to: nxp_question.zip

Labels (4)
Tags (1)
0 Kudos
3 Replies

301 Views
himalimunshi
Contributor I

hello Gaurav,

try to build recipe individually for that you can use these commands:

bitbake -f -c cleansstate elfutils-native

bitbake -f -c configure elfutils-native

bitbake -f -c compile elfutils-native

bitbake -f -c install elfutils-native

You can replace recipe name in above commands which is going to fail while your image building.

After building all those packages/recipe individually which are giving error while building Image, You can build Image. 

0 Kudos

301 Views
jaymind
Contributor IV

Hi Gaurav,

First, you can avoid the "WARNING" related to host distribution.

Second, regarding the errors you are facing while bitbaking.

Listing down some must have packages required for Yocto on host distribution. So, verify this first. (Execute below commands).

$ sudo apt-get install gawk wget git-core diffstat unzip texinfo gcc-multilib build-essential chrpath socat libsdl1.2-dev xterm sed cvs subversion coreutils texi2html docbook-utils python-pysqlite2 help2man make gcc g++ desktop-file-utils libgl1-mesa-dev libglu1-mesa-dev mercurial autoconf automake groff curl lzop asciidoc

Additional configurations/packages:

$ sudo dpkg --add-architecture i386
$ sudo apt-get update
$ sudo apt-get install g++-5-multilib
$ sudo apt-get install curl dosfstools gawk g++-multilib gcc-multilib lib32z1-dev libcrypto++9v5:i386 libcrypto++-dev:i386 liblzo2-dev:i386 libstdc++-5-dev:i386 libusb-1.0-0:i386 libusb-1.0-0-dev:i386 uuid-dev:i386

$ cd /usr/lib; sudo ln -s libcrypto++.so.9.0.0 libcryptopp.so.6

Also, as per your log (line no. 37 and 1517) it can't find the Kernel source on git repo for imx_3.14.52_1.1.0_ga branch.

Please, share your "local.conf" as well. It will be easier to find out the solution.

Jaymin

0 Kudos

301 Views
b45499
NXP TechSupport
NXP TechSupport

Ubuntu-16.04 is work well for our BSP, details you can refer to the i.MX_Yocto_Project_User's_Guide. In the document there are details on ubuntu host setting.

0 Kudos