Unable to run Xen hypervisor on IMX8QM-MEK

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Unable to run Xen hypervisor on IMX8QM-MEK

151 Views
LokeshGandham
Contributor I

I'm following 5.6.11 in IMX Yocto Project user guide for Xen building.

In the local.conf I added below

```DISTRO_FEATURES:append = " xen" ```

Once the build is complete, I'm preparing SD card with

```sudo dd if=core-image-rootfs.wic.zst of=/dev/sdx bs=1M conv=sync.```

I'm unable to find imx8qm-mek-dom0.dtb  file in the build,

in the Uboot  when I execute "run xenmmcboot" I was getting the below error.

```
=> run xenmmcboot
Failed to load 'xen'
Failed to load 'imx8qm-mek-dom0.dtb'
106496 bytes read in 3 ms (33.9 MiB/s)
Loading hdp firmware from 0x000000009c000000 offset 0x0000000000002000
Loading hdp firmware Complete
32262656 bytes read in 378 ms (81.4 MiB/s)
Working FDT set to 83000000
libfdt fdt_path_offset() returned FDT_ERR_NOTFOUND
libfdt fdt_path_offset() returned FDT_ERR_NOTFOUND
## Flattened Device Tree blob at 83000000
Booting using the fdt blob at 0x83000000
Working FDT set to 83000000
Using Device Tree in place at 0000000083000000, end 000000008302efff
Working FDT set to 83000000

Starting kernel ...

"Synchronous Abort" handler, esr 0x02000000
elr: 000000007a60106c lr : 0000000080021f78 (reloc)
elr: 0000000081bf806c lr : 0000000087618f78
x0 : 0000000083000000 x1 : 0000000000000000
x2 : 0000000000000000 x3 : 0000000000000000
x4 : 0000000080200000 x5 : 0000000000000001
x6 : 0000000000000008 x7 : 0000000000000000
x8 : 0000000000002054 x9 : 0000000000000002
x10: 000000000a200023 x11: 0000000000000002
x12: 0000000000000002 x13: 0000000000000000
x14: 0000000085205290 x15: 0000000087617e98
x16: 0000000087667ee0 x17: 0000000000000000
x18: 0000000085216d30 x19: 00000000876e9478
x20: 0000000000000400 x21: 0000000000000000
x22: 0000000000000003 x23: 0000000085255058
x24: 00000000876d2318 x25: 0000000000000000
x26: 0000000000000400 x27: 0000000087618f94
x28: 0000000000000000 x29: 0000000085204860

Code: cccccccc cccccccc cccccccc cccccccc (cccccccc)
Resetting CPU ...

### ERROR ### Please RESET the board ###

```

Thanks in Advance,

 

0 Kudos
1 Reply

129 Views
Bio_TICFSL
NXP TechSupport
NXP TechSupport

Hello,

It looks like you have an error in your dtb since XEN hypervisor works nicely in my MX8QM.

Regards

0 Kudos