Sabre Lite Board jumps to invalid address after boot from SD

cancel
Showing results for 
Search instead for 
Did you mean: 

Sabre Lite Board jumps to invalid address after boot from SD

309 Views
hazal_pektas
Contributor I

I am trying to boot Sabre Lite board from SD card on WEC2013 with Adeneo BSP. The image which is a simple hello world application, is also written to SD card via cfimager. I have written "eboot.nb0" and "NK.nb0" files to the SD card with cfimager. Getting outputs to the serial console with TeraTerm. I saw below lines on TeraTerm:

Press [ENTER] to launch image stored in SD/MMC or [SPACE] to cancel.

Initiating image launch in 59 seconds.

-----------------------------------------------------------------------------
Freescale iMX SOC Menu Item
-----------------------------------------------------------------------------
 [0] IP Address : 192.168.111.10
 [1] Set IP Mask : 255.255.255.0
 [2] Boot Delay : 60
 [3] DHCP : Disabled
 [4] Reset to Factory Default Configuration
 [5] Select Boot Device : NK from SD/MMC
 [6] Set MAC Address : 0-2-B3-92-A8-C4
 [7] Format OS NAND Region
 [8] Format All NAND Regions
 [9] Bootloader Shell
 [I] KITL Work Mode : Polling
 [K] KITL Enable Mode : Disable
 [P] KITL Passive Mode : Disable
 [S] Save Settings
 [D] Download Image Now
 [L] Launch Existing Flash Resident Image Now
 [E] Select Ether Device : USB Serial
 [M] MMC and SD Utilities
 [R] Reinit Display
 [F] NAND Low Level Format
 [U] Set UUID : FF-FF-FF-FF-FF-FF-FF-FF-FF-FF-FF-FF-FF-FF-FF-FF

 Selection: l
-BLMenu .
INFO: Using device name: 'MX6Q64378'
INFO: Reading NK image to SDHC (please wait)...
INFO: Copying NK image to RAM address 0xa0200000

INFO: Read is 100% complete
INFO: Copy of NK completed successfully
Download successful! Jumping to image at 0x10200000 (physical).....

After that nothing jappens, and I can not see the serial traces.  Any help will be appreciated. Thanks in advance. I also tried Windows Embedded CE Boot Problem from SD Card  this solution, but could not succeed.

0 Kudos
2 Replies

98 Views
hazal_pektas
Contributor I

I solved the problem, I was writing SD card with cfimager, but I was trying to write the image without partition (-a command), so the NK.nb0 file was not written on SD card, and the older image was there to run. Main problem is that, Adeneo BSP was used for the OS design, but the old image was a GuruCE image which is not compatible with Adeneo bootloader and leading to jumping an empty address. 

0 Kudos

98 Views
CarlosCasillas
NXP Employee
NXP Employee

Deactivated user‌, are you able to help on this case?

0 Kudos