M4core setup for imx8 QXP mek (with Zephyr Project)

Showing results for 
Search instead for 
Did you mean: 

M4core setup for imx8 QXP mek (with Zephyr Project)

Contributor I


I am using Zephyr Project to build applications for the M4core on my imx8 qxp mek board. I started with the Hello World sample application provided with Zephyr and I used my board's specific settings to do that. The compile was successfull but I had some difficulties and misunderstandings when I tried to load the generated binary file into the board and run it from memory. I do not know exactly what I am doing wrong but I still can’t get the expected output. In my head, to know I’ve done the things right, I think I should see some “Hello World” message on terminal after I run the bin file from memory, but I didn’t manage to get that “Hello world” message.

Anyways, I used an sdcard and the u-boot fatload command to load the file into the board to a certain memory address. After that I used the bootaux command to start the M4 core from that specific memory address. I received this message  “Copy image from 0x80280000 to 0x34fe0000 Start M4 bootaux complete” which tells me that I've done the things correctly. The problem is that I didn't get that "Hello World" message I expected. If I try to run ‘go 0x80280000’,  ‘go 0x34fe0000’, or to go to any other memory address my board is just resetting and freezes. I tried to run the bootaux command again and switch back to the main core where I did not get this weird behaviours, but the same thing happened, freezing and every time I have to manually reset the board.


Furthermore, I realised that no matter what memory address I use to start the M4 core, I still get that message saying that M4 core was succesfully started and the bootaux was complete, even though I didn't load any binary file to that address.

 I do not know if this was supposed to happen or what I am doing wrong if not, so can you please help me?


0 Kudos
1 Reply

NXP TechSupport
NXP TechSupport

Hi Radu-Stefan

one can try to debug it using  iar_segger_support_patch_imx8 mentioned on
Using JLink Debugger for M4 software on IMX8M 

also may be useful to check MCUXpresso SDK for i.MX Cortex-M i.MX8QXP from :

Alpha / Beta BSPs for Microprocessors|NXP 

Best regards
Note: If this post answers your question, please click the Correct Answer button. Thank you!

0 Kudos