IMX6Q Sabre Yocto build fail

Showing results for 
Search instead for 
Did you mean: 

IMX6Q Sabre Yocto build fail

Contributor I

Hi everyone,

I try to build Yocto for IMX6Q Sabre based on distro fsl-imx-xwayland with one more additional layer from Laird Connectivity because I have one more module wifi from LAIRD:

GitHub - LairdCP/meta-laird-cp: Example Yocto/OE layer for integrating Laird's 60 series radio modul... 

However I had build error:

ERROR: sterling-supplicant- do_packagedata: The recipe sterling-supplicant is trying to install files into a shared area when those files already exist. Those files and their manifest location are:
(matched in manifest-imx6qpsabresd-wpa-supplicant.packagedata)
(matched in manifest-imx6qpsabresd-wpa-supplicant.packagedata)
(matched in manifest-imx6qpsabresd-wpa-supplicant.packagedata)
(matched in manifest-imx6qpsabresd-wpa-supplicant.packagedata)
Please verify which recipe should provide the above files.

Summary: 1 task failed:
Summary: There were 13 WARNING messages shown.
Summary: There were 3 ERROR messages shown, returning a non-zero exit code.

I try to config PREFERRED_PROVIDER in the local.conf but no success:

PREFERRED_PROVIDER_wpa-supplicant-cli = "sterling-supplicant"
PREFERRED_PROVIDER_wpa-supplicant-passphrase = "sterling-supplicant"

Please help to resolve this problem.

Thanks and best regards,


0 Kudos
4 Replies

Contributor IV

Have you tried manually removing the files reported in error log and rebuild? You could also remove the whole tmp directory however it will take more time to rebuild.

0 Kudos

Contributor I


I tried the new build but no success, so I try to change the seting in menuconfig to disable this features with these commands:

host$ bitbake -c menuconfig virtual/kernel

host$ bitbake virtual/kernel -c compile     
host$ bitbake virtual/kernel -c deploy    

and then build the image again, however nothing change. I think my new menuconfig is not effect to the bitbake build. Do I change the menuconfig correctly?

0 Kudos

Contributor I

Just for future reference, if using bitbake -c menuconfig virtual/kernel, it is not guaranteed that bitbake will compile the kernel after saving the .config. If the output from bitbake -c compile does not result in the kernel being recompiled, use bitbake -c compile -f to force recompile. Another option is to bitbake -c clean virtual/kernel before menuconfig, however this will revert the kernel's .config to the defconfig state if changes were made previously.

0 Kudos

NXP Employee
NXP Employee


I apologize for the delay.

To run the menu config for Yocto, you can do it as below:

$ bitbake linux-imx -c menuconfig

However, running this configuration will not guarantee to have the changes in your end image.

What I suggest you, is to create a Yocto recipe that will modify the default configurations with the new ones. I recommend you to follow the below Document.

Hope this information can help you.

Best regards,


0 Kudos