Can't Start Debug Session through USB Multilink Universal

cancel
Showing results for 
Search instead for 
Did you mean: 

Can't Start Debug Session through USB Multilink Universal

565 Views
Contributor II


I use S32 Design Studio to develop on Panther MPC5744p. But I got some troubles to flash executable.

 

When I start debug mode in NXP S32 Design Studio with USB Multilink Universal, I got message popped up, "Reset scriptfile may have caused loss of communications. Disable reset scriptfile? Yes or No", then "The target may have entered reset escalation. Please power cycle the board.", then on console an error shown up, "error in ONCE status register occurred during instruction executes."

 

I don't what's going on. I think I have updated the driver and firmware. The both LEDs on the multilink tool are illuminated when connected to target and PC.

 

Do you have any idea for the errors?

Labels (2)
2 Replies

14 Views
Contributor II

I remember the cut is 1N65P. Actually it's not Panther EVB but the company's hardware. We finally found the root cause from the external watchdog. We don't serve WDT, so it just generates RESET periodically. Now we disabled it temporarily for debugging and HW test.

So the issue has been solved.

Thank you,

14 Views
NXP Employee
NXP Employee

Hi,

I tried to flash and debug one of my project for MPC5744P and I cannot reproduce the problem. I also use Multilink Universal and Cut is 2.2B (mask 1N15P).

Could you please clarify your Cut (or mask)?

Did you update the firmware using S32DS or did you download firmware from PeMicro website? Sometimes, when drivers are outdated, S32DS offers you to update firmware.

I expect you use NXP EVB board, don't you?

Regards,

Martin

0 Kudos