PN7462AU - Problems with communication - ID: 0x00000000

Showing results for 
Search instead for 
Did you mean: 

PN7462AU - Problems with communication - ID: 0x00000000

Contributor II


I try to run my own borad with PN7462AU. It is simple board based on typical application (Fig 18. in AN11706). I think the chip is soldered correctly (I have the same problem in two boards). Board is supplied from 5V. Measured voltages:

VBUS = 5,04V

PVDD_OUT = 3,28V

VDD = 1,83V

I use LPC-Link2 and LPCXpresso v8.2.2 and I try to run software examples form NXP. Problem is the same in all examples e.g when I try to run "NfcrdlibEx1_BasicDiscoveryLoop" example, project build correctly and the debug starts.

Debug messenges :

"LPCXpresso RedlinkMulti Driver v8.2 (Sep  5 2016 10:12:38 - crt_emu_cm_redlink build 725)
============= SCRIPT: PN7xxxxx_Connect.scp =============
DpID = 0BB11477
APID = 0x04770021
============= END SCRIPT ===============================
Probe Firmware: LPC-LINK2 CMSIS-DAP V5.173 (NXP Semiconductors)
Serial Number:  I3FWNRAS
VID:PID:  1FC9:0090
USB Path: \\?\hid#vid_1fc9&pid_0090&mi_00#7&1b9a9635&0&0000#{4d1e55b2-f16f-11cf-88cb-001111000030}
Emu(0): Connected&Reset. DpID: 0BB11477. CpuID: 410CC200. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
inspected v.2 On-chip Flash Memory C:\nxp\LPCXpresso_8.2.2_650\lpcxpresso\bin\Flash\PN7xxxxx_154k.cfx
image 'PN7xxxxx_154k Mar  8 2016 16:35:09'
NXP: PN7462AU-C2-00  Part ID: 0x00000000
Connected: was_reset=true. was_stopped=false
LPCXpresso Free License - Download limit is 256K
Opening flash driver C:\nxp\LPCXpresso_8.2.2_650\lpcxpresso\bin\Flash\PN7xxxxx_154k.cfx
Writing 86992 bytes to address 0x00203000 in Flash
Erased/Wrote page  0-42 with 86992 bytes in 1941msec
Flash Write Done
Flash Program Summary: 86992 bytes in 1.94 seconds (43.77 KB/sec)

Stopped: Breakpoint #1

I assume that Part ID: 0x00000000 is incorrect. Maybe someone knows what could be the reason ?

Despite this debug starts. But when I resume project it stops on line (in phFlashBoot.c):

"    /* Ensure the Major version of EEPROM is correct
     * Warning: Firmware might be tightly linked with the EEPROM contents and layout.
     * If there is a mismatch please do upgrade.
     * */


The problem is the same in all examples in two the same boards, always ID: 0x00000000. I have no idea of the problem is on hardware (wrong application - I don't think so because voltage measured look properly)  or software (maybe I should change something in example properties or something is wrong in LPC-Link2) ?

Thank you for your help.

Labels (2)
0 Kudos
2 Replies

NXP Employee
NXP Employee

Hi Adrian,

The example projects for PN7462 are expecting an EEPROM firmware version which is most probably not installed in your new ICs.

Please load the binary file called "user_ee.bin" located in the next path:


You can follow the instructions in the next document to load the binary. Just pay attention that for EEPROM the selected Flash driver must be "PN7xxxxx_EE_3_5k.cfx" and the base address must be 0x201200.

Using the GUI flash programming tool 

Best Regards!,
Jorge Gonzalez

Note: If this post answers your question, please click the Correct Answer button. Thank you!

Contributor II

Hi Jorge,

Thank you for your answer. Unfortunately, the problem is not solved completely but your answer was helpful. First problem arises with the launch "Program Flash" in the toolbar, LPCXpresso it connects succesfully to the LPC-LINK 2. Then gets the message:


When i click "OK" on this error window, "Program Flash" starts despite the error. According to your instructions I set the following parameters:


Report of flash programming:


After starting debug, program debugs further but now program lost in function: phOsal_StartScheduler();

So that problem was solved only in small part, program debugs further but lost in another place...

Still there is something wrong because on debug messenges Part ID 0x00000000. I think that is not correct.

I have the following software:


LPCXpresso V8.2.2 [Build 650], Plugin in the latest version.

Why I have problem with correct launch "Program Flash", what could be the reason for the lack of reading ID ? Maybe something I should install / configure ?

Thanks for your interest in and support.

Best Regards,
Adrian Pakosinski

0 Kudos