CW 10.1, MQX 3.7, twrk60n512 gives me a #error in mqx.h

cancel
Showing results for 
Search instead for 
Did you mean: 

CW 10.1, MQX 3.7, twrk60n512 gives me a #error in mqx.h

Jump to solution
2,189 Views
gloucks
Contributor III

when building bsp_twrk60n512. from mqx.h:

 

/* CW 10.1 Cortex compiler 2402 build patch */
#if (__arm__)
#if (__CWBE__ < 0x05000200)
#error  You need to install Code Warrior V10.1 latest compiler patch. The code is unstable if patch is not used.
#endif
#endif

 

Installed Products:
 - CodeWarrior for MCU
     Version: 10.1
     Build Id:110204

 

Host is Windows (XP64).

0 Kudos
1 Solution
114 Views
gloucks
Contributor III

Awesome! Works great, thanks. :smileyvery-happy:

View solution in original post

0 Kudos
15 Replies
114 Views
GaQuay
Contributor I

I have this problem, and did what recomended. It did not work.

I am using windows 7 64 bit

Any solution?

0 Kudos
114 Views
BrianMoon
Contributor II

It doesn't work for me either.

0 Kudos
114 Views
bhaskar_naik
Contributor I

It works with WinXP system. But WIN7 we are getting the same error.

0 Kudos
114 Views
Fermi_desarroll
Contributor I

I have winxp and not work, the upgrade tell me "An error occurred while collecting items  to bi installed"

0 Kudos
114 Views
bhaskar_naik
Contributor I

There is an Update Procedure document that explains how to install the Compiler Update (http://cache.freescale.com/files/soft_dev_tools/doc/support_info/CW_MCU_v10.1_Update_Procedure.pdf?f...) in offline or online mode. 

Try using off-line mode.

0 Kudos
114 Views
DavidS
NXP Employee
NXP Employee

There is a compiler patch that must be applied.  Below are links and instructions to do so.

 

CW MCU v10.1 Compiler (ColdFire, Kinetis) Update and MQX 3.7  available on the WEB.

 

The Compiler Update can be found on the CW MCU 10 Overview WEB page (http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=CW-MCU10&tid=CWH) and the CW MCU v10.1 Updates & Patches WEB page (http://www.freescale.com/webapp/sps/site/overview.jsp?nodeId=0152102726006178829C6FBD0B). There is an Update Procedure document that explains how to install the Compiler Update (http://cache.freescale.com/files/soft_dev_tools/doc/support_info/CW_MCU_v10.1_Update_Procedure.pdf?f...) in offline or online mode. The Compiler Update should be installed before MQX 3.7.

 

Please note there is a known bug in the “Check for Updates” menu item in the Help Menu.  It will always report there are no updates available. The Update Procedure also explains how to add a “/” to the Freescale URL to ensure  all updates can be downloaded and installed using the “Install New Software” item in the Help Menu.

 

MQX v3.7 can be found on the Download TAB of the Freescale MQX Software Solutions WEB page (http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=MQX&nodeId=0152106079). The direct link to the Download TAB is http://www.freescale.com/webapp/sps/site/prod_summary.jsp?code=MQX&nodeId=0152106079&fpsp=1&tab=Desi....

 

 

Hope this helps.

Regards,

David

0 Kudos
114 Views
HeMyFAE
NXP Employee
NXP Employee

This post is coutesy on behalf of Brian M.

 

1. Uninstalled CW10.1

2. Uninstalled MQX 3.7

3. Re-installed CW10.1 to a non-default folder -> "c:\Users\Public\Freescale\CW MCU v10.1"

4. Re-installed MQX 3.7 to a non-default folder -> "c:\Users\Public\Freescale\Freescale MQX 3.7"

5. Updated CW10.1 with the required patches (this took two tries, including application restarts, but seems to have worked)

 

Now, the Feature information indicates com.freescale.mcu is 10.1.5!!! So, the trick is to NOT INSTALL CW10.1 in the default folder! Something very subtle seems to go wrong if CW10.1 is installed in the default folder.

 

I hope this helps you support others.

 

 

0 Kudos
114 Views
SimonMarsden_de
Contributor II

I also have the problem. I have updated to the latest CW 10.1 using the following patch:

MCU v10.1 Compiler Update for Linux. Prerequisite for MQX v3.7: Addresses ColdFire, Kinetis and Qorivva compiler issues. Size (K): 75073 Format: zip Rev #: 1.0.2 Modified: 5/26/2011

In case it's relevant, I'm using 32-bit Windows Vista Service Pack 2 with CW installed in the default location.

 

The patch seems to have installed, in that the version reported looks correct and attempts to repeat the installation get an 'already installed' error.

 

However by messing around with the 'preprocess' option I discovered that the value of __CWBE__ is 0x3201

 

I really don't want to have to download hundreds of megabytes yet again and reinstall CW10.1 in a non-default location, just to see if it will make a difference.

 

I hate CW10 ! Can't we go back to the old classic version which was easy and worked well - or use the IAR tools?

 

0 Kudos
114 Views
CarlFST60L
Senior Contributor II

Hi Simon,

 

You should just be able to uninstall and reinstall to get it to work, install it in the non default location. Also, if you use MQX, this means you will need to change the path in the properties to get it to work.

 

I really do feel your pain. I struggled for months to feel comfortable in CW10.1, especially after spending years in the previous platform. The good news is, even though you will have to put some effort into working around many issues and undocumented/poorly document issues, CW10.1 is a step in the right direction for everyone. I have just started testing CW10.2, lets hope this is a little more stable!

 

At some point I want to make a Youtube video with some of the work arounds and tips n tricks I have learnt over hte last 12 months, I just need to find half a day and a little motivation!

0 Kudos
114 Views
CarlFST60L
Senior Contributor II

I feel your pain Simon, I have just gone from classic (10 year veteran) to CW10.1, and found it to be a total mess... And now I have been waiting three days for support to get back to me and no result (and I am a yearly subscriber)...

 

I ended up running the installers in admin mode, then setup CW10.1 to launch as admin and it appears to have fixed some things, but many others still down work, like, -IR (recursive includes), but some how only for the IDE, and the projects are mostly broken because of this problem making them almost un-readable. To get the eGUI demo going I had to basically go and manually add every single folder to get them to link and work properly... I have stopped working with their products until support get me a completely working demo, or tell me how to get CW10.1 to do what it is suppose to do.

0 Kudos
114 Views
Gargy
NXP Employee
NXP Employee

Hi,

the error what you see in CW10.1 in eGUI MQX 3.7 demo should be done by missing Touch screen driver in MQX . You have to recompile MQX with enabled TOUCH SCREEN driver in mqx config file.

 

#define BSPCFG_ENABLE_TCHSRES    1

 

Try it and let me know, if this helps you.

 

Have a nice day

Gargy

0 Kudos
114 Views
FabianS
Contributor II

I had the same problems with CodeWarrior 10.1 SE on Windows 7 64-Bit. He asked for a license and I got the error complaining about missing compiler patch. After reinstalling MQX and CodeWarrior into my private folder all problems were gone. Thanks alot!

0 Kudos
114 Views
dnappier
Contributor I

One solution that I used that has worked for me and should work no matter what system you are using is to edit the library file containing mqx.h. I opened the psp library build project for my specific processor contained in the sub folder. I then opened up mqx.h and commented out the compiler patch check. After this is done you have to recompile all of the libraries, according to Freescales documentation. Make sure you do it as both release and debug. This will get rid of the error. I don't exactly feel good about editing this file but if you are tired of dealing with this problem then this is a solution. 

0 Kudos
114 Views
yb
Contributor IV

Hi,

Another solution on Windows 7, Properties on the c:\Programmes Files\Freesclae\CW MCU v10.1\eclipse\cwide.exe

then compatibilities (I don't know if it's the exact term, my OS is in french...) and check the "execute this program in administrator mode" box.

 

0 Kudos
115 Views
gloucks
Contributor III

Awesome! Works great, thanks. :smileyvery-happy:

View solution in original post

0 Kudos