Question about MPC5746R_MCAL4_0_RTM_HF1_1_0_3

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Question about MPC5746R_MCAL4_0_RTM_HF1_1_0_3

628 Views
hongpingxu-b364
NXP Employee
NXP Employee

Hi

 

My customer migrated MPC5746R MCAL from MPC5746R_MCAL4_0_RTM_1_0_3 to MPC5746R_MCAL4_0_RTM_HF1_1_0_3. But they met ADC License issue and have to revised ADC back to the previous MPC5746R _ MCAL 4 _ 0 _ RTM _ 1 _ 0 _ 3 version and can work now.

1.jpg

Customer comparing these two versions of the code package as follows:

2.jpg

As shown in the figure, the old version code package MPC5746R _ MCAL 4 _ 0 _ _ RTM _ 1 _ 0 _ 3 The other modules except the ADC module are identical, and the ADC module has signature information, which can be imported into EB.

3.jpg4.jpg

As shown in the figure, the latest version of MPC5746R _ MCAL 4 _ 0 _ M _ RTM _ HF 1 _ 1 _ 0 _ 3 code package, there is a macro defined judgment, there is no judgment in START, the judgment in STOP.

 

So, please help clarify which version of the published code package can be use. Normally, we should follow the latest version. Does the latest released version need to be corrected?

0 Kudos
Reply
3 Replies

558 Views
hongpingxu-b364
NXP Employee
NXP Employee

Hi,

My customer confirmed that the EB version used version 14.2.1 and did not modify the code package. Could you please help to check whether the uploaded latest code package lacks the lic of the ADC module, and the code?

In addition, do you have any operational process guidance for switching code packs? It’s helpful for my customer to switch the project.

BR,

Hornby

0 Kudos
Reply

553 Views
namnguyenviet
NXP Employee
NXP Employee

Hello @hongpingxu-b364 

I checked the ADC plugin and it looks like the CRYPTOMANIFEST.MF has missed the hash info. I will ask the team to re-generate the plugin.

Regarding the switching code packs, an EB project can only allow one driver version, and it isn't possible to switch between driver versions.

Best Regards,

Nam

0 Kudos
Reply

610 Views
namnguyenviet
NXP Employee
NXP Employee

Hello @hongpingxu-b364 

Normally, customers should use the latest package, in this case, it's 1.0.3 RTM_HF1. Please make sure that customers didn't modify any file in the package, otherwise the modification will lead to license violation. They can also try to uninstall and install again. Also, make sure that they are using EB 14.2.1.

Best Regards,

Nam

0 Kudos
Reply