I get the following error when i laund the S32 IDE

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

I get the following error when i laund the S32 IDE

Jump to solution
1,344 Views
MattJCole
Contributor V

 

I reinstalled the S32 Design Studio for Power Architecture Version 2.1. Know when try to use an example project i get the following error message.

MattJCole_0-1678917788539.png

 

0 Kudos
1 Solution
1,302 Views
MattJCole
Contributor V

I found the problem. When I installed the S32 SDK 3.0.3 using the S32DS Extensions and updates popup to install the SDK the path for the SDK was wrong. When I went to Preferences->”Processor Export”->”Repositories and Paths” the setting for SDK_S32_PA_15 had an error stating that the directory didn’t exist. The problem is that in the path it had S32_SDK_S32_PA_RTM_3.0.3 instead of S32_SDK_S32PA_RTM_3.0.3. I think you should have someone at NXP investigate it. I think someone did a simple typo.

View solution in original post

0 Kudos
7 Replies
1,303 Views
MattJCole
Contributor V

I found the problem. When I installed the S32 SDK 3.0.3 using the S32DS Extensions and updates popup to install the SDK the path for the SDK was wrong. When I went to Preferences->”Processor Export”->”Repositories and Paths” the setting for SDK_S32_PA_15 had an error stating that the directory didn’t exist. The problem is that in the path it had S32_SDK_S32_PA_RTM_3.0.3 instead of S32_SDK_S32PA_RTM_3.0.3. I think you should have someone at NXP investigate it. I think someone did a simple typo.

0 Kudos
693 Views
christofer_ft
Contributor I
Hello,

I have the same SDK_S32_PA_15 problem too. I can't find the S32DS Extensions and updates menu. Do you know where I can find it?

I've checked the folder mentioned above, and navigate to S32DS_Power_v2017.R1\S32DS\S32_SDK_S32PA_RTM_3.0.0\tools\pex\Repositories, i can find only the SDK_S32_PA_11_Repository.

Best regards.
0 Kudos
1,255 Views
petervlna
NXP TechSupport
NXP TechSupport

Hello,

Nice to hear that.

I have reported it to S32DS team.

Best regards,

Peter

0 Kudos
984 Views
saichinnala
Contributor II

hello sir,

i am using example code of sbc_f65 ,i am able to communicate but read data am not able to store in local buffer.

0 Kudos
1,306 Views
MattJCole
Contributor V

This problem doesn’t seem to affect the S32_SDK_S32PA_RTM_3.0.0 projects. I installed S32_SDK_S32PA_RTM_3.0.3 using the S32DS Extensions and updates popup that appears when you launch the IDE. It appears to have installed the SDK with no issues but when you try to use it doesn’t work. My current single core project uses S32_SDK_S32PA_RTM_3.0.3. There was an issue with my IDE that prevented multicore projects from working so in reinstalled the IDE. For some reason the SDK S32_SDK_S32PA_RTM_3.0.3 does not work anymore. Do you know where the SDK_S32_PA_15 is defined?

0 Kudos
1,310 Views
MattJCole
Contributor V

When I go to the directory every thing looks okay. There is a  C:\NXP\S32DS_Power_v2.1\S32DS\software\S32_SDK_S32PA_RTM_3.0.3 and that is what it is supposed to be pointing to but for some reason it keep think it is a Kinetis project and wants the KSDK. I do have Kinetis Design Studio 3 IDE installed for the legacy system but the new project uses the MPC5748G. What can be causing this?

0 Kudos
1,322 Views
petervlna
NXP TechSupport
NXP TechSupport

Hello,

I am not sure what causing this issue. Maybe some restrictions set by your PC.

Could you please check whether you have installed S32DS in c:\NXP\S32DS_Power_v2.1\S32DS\software\ ?

And also check you PC for missing file PA_15?

Best regards,

Peter

0 Kudos