MCUXpresso: Require extra mouse clicks for SWO ITM Console with JLink

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MCUXpresso: Require extra mouse clicks for SWO ITM Console with JLink

123 Views
rshipman
Contributor V

Hi,

I am using the SWO ITM Console with a SEGGER JLink to print debug to the MCUXpresso console. This works, but it is a bit of a fiddle each time I start a debugger session.

I put a breakpoint at the end of my InitBoard() function so that I know the trace clock and pins etc are all set up properly. When the debugger gets to this breakpoint, I then enable the SWO ITM Console and then allow the app to continue. I see debug coming out of the main MCUXpresso Console window as expected.

Question 1:

One problem is that I get this pop up:

"Configure SWO: Unable to set baud for prescaler. Wanted 1 but got back 2. Please check your Clock Speed setting from Clock speed configuration."

When I click ok, this does not seem to affect the debug session. I jump over the breakpoint and then continue the session as normal.

What is this message actually telling me? The firmware running on the RT1021 does all the trace clock setup. I don't know what MCUXpresso is trying to do here.

 

Question 2:

In total I have to click on 4 things after it hits the breakpoint to get my session working again with SWO debug. It would be 3 without that pop-up. There must be an easier way. Is there a way I can set up MCUXpresso with the JLink so that I don't need to click anything extra?

Info:

  • MCUXpresso 11.8.1
  • SDK (RT1021) 2.14.0
  • SEGGER JLink Pro with V7.94h firmware

 

Many thanks.

Tags (3)
0 Kudos
1 Reply

63 Views
EdwinHz
NXP TechSupport
NXP TechSupport

Hi @rshipman,

I believe the SWO viewer is trying to set a specific baud rate, but the MCU is operating at another. Therefore, it has to change it "on the fly", which is why it still works, but it still shows a message to warn about it. Check the clocking configurations and make sure that both the MCU and the host are synchronized. I believe this should remove the pop-up message and prevent that extra click.

BR,
Edwin.

0 Kudos