MCUXpresso: JLink script path does not recognise ${ProjDirPath}

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

MCUXpresso: JLink script path does not recognise ${ProjDirPath}

158 Views
rshipman
Contributor V

Hi,

I'm trying to set a relative path to the JLink script for my project. The JLink script is in the same folder as the .launch files. Here is the sequence:

  • Double left-click on the .launch file from the Project Explorer window in MCUXpresso.
  • Select JLink Debugger tab.
  • Scroll down to Additional options.
  • Fill the Script field with the path
  • Continue and save etc.

So if I enter an absolute path to the JLink script, it all works fine and I can debug my code.

If I try any of the following, then it fails to work (and I get 0xdeadbeee in the callstack).

  • ${ProjDirPath}/Default.JLinkScript
  • Default.JLinkScript
  • ./Default.JLinkScript
  • ../Default.JLinkScript
  • ../../Default.JLinkScript

I've tried the above with forward and backward slashes.

Is there a way of using relative paths in this field, ideally with ${ProjDirPath} please?

What is the default folder for this field?

What is interesting is that the 'Settings file' field does use ${ProjDirPath} so I am assuming it should work in the Script field.

Info:

  • MCUXpresso 11.8.1
  • SDK (RT1021) 2.14.0
  • SEGGER JLink Pro with V7.94h firmware

 

Kind regards.

0 Kudos
1 Reply

130 Views
ErichStyger
Senior Contributor V

I can confirm the problem, and reported this I believe back in December 23, so this might get fixed in the future.

I'm not aware of any other workaround than using an absolute path.

The other workound would be to use the Eclipse Embedded CDT (C/C++ Development Tools, formerly GNU MCU/ARM;Eclipse) plugin which includes a SEGGER J-Link launch configuration.

I hope this helps,

Erich

0 Kudos