Debug buttons suddenly grayed out

cancel
Showing results for 
Search instead for 
Did you mean: 

Debug buttons suddenly grayed out

346 Views
janblumenkamp
Contributor I

Hello,

I am using MCUXpresso IDE v10.2.0 [Build 759] [2018-05-15] on Linux, v.4.9.114-1-MANJARO, x86_64 / gtk 2.24.32. Since some time I have big problems with the debugging. With LPCXpresso and also with the first versions of MCUXpresso everything worked fine. Sometimes when I start debugging, the debugging toolbar looks like this. Everything is fine:

debug_toolbar_ok.png

But as soon as I start debugging, the debugging buttons gray out like this as soon as the program hits a breakpoint:

debug_toolbar_err.png

The only thing I can do from here is click the outermost stop button with the x ("Clean up debug") and restart debugging. At this point I also can't inspect variable contents. There is no error message, no window pops up or something that indicates what might have gone wrong... Sometimes restarting debugging even only works after plugging the LPC-Link 2in and out again. This is most likely no issue with the LPC-Link since the problem persists with a different one.

This is super annoying, productive work is impossible.

Is there any idea what might be the reason for this?

Best,

Jan

Tags (2)
0 Kudos
1 Reply

171 Views
converse
Senior Contributor IV

It is probably because your application is no longer selected in the Debug view. The Debug view is where you can see you application and the call stack. Make sure one of the functions in your call stack is selected.

0 Kudos