LPC17xx - Cannot halt process issue

cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

LPC17xx - Cannot halt process issue

439 Views
software3
Contributor I

Hello everybody, 

I'm stuck with a "Cannot halt process" issue while trying to program a LPC17xx MCU on a custom board. I've loaded in debug mode several time the same project without any problem, but at a certain point it stopped working and I can't program che chip anymore. I've tried to follow the instructions about Regaining debug access to target MCU , but unfortunately I still can't access the chip in any mode. 

I've also tried to erase the Flash memory from "Debug configuration" window, but it gave me back the same error. 

This are the console messages when I launch the debug:

MCUXpresso IDE RedlinkMulti Driver v10.2 (Jul 25 2018 11:25:37 - crt_emu_cm_redlink build 555)
Reconnected to existing link server
Connecting to probe 1 core 0:0 (using server started externally) gave 'OK'
Probe Firmware: LPC-Link Probe v1.3 (NXP - LPC-Link)
Serial Number: HID64HS12
VID:PID: 1FC9:0007
USB Path:
Using memory from core 0:0 after searching for a good core
debug interface type = Cortex-M3/4 (DAP DP ID 2BA01477) over SWD TAP 0
processor type = Cortex-M3 (CPU ID 00000C23) on DAP AP 0
number of h/w breakpoints = 6
number of flash patches = 2
number of h/w watchpoints = 4
Probe(0): Connected&Reset. DpID: 2BA01477. CpuID: 00000C23. Info: <None>
Debug protocol: SWD. RTCK: Disabled. Vector catch: Disabled.
Content of CoreSight Debug ROM(s):
RBASE E00FF000: CID B105100D PID 0000000000 ROM dev (type 0x1)
ROM 1 E000E000: CID B105E00D PID 04002BB000 ChipIP dev SCS (type 0x0)
ROM 1 E0001000: CID B105E00D PID 04002BB002 ChipIP dev DWT (type 0x0)
ROM 1 E0002000: CID B105E00D PID 04002BB003 ChipIP dev FPB (type 0x0)
ROM 1 E0000000: CID B105E00D PID 04002BB001 ChipIP dev ITM (type 0x0)
ROM 1 E0040000: CID B105900D PID 04002BB923 CoreSight dev TPIU-Lite type 0x11 Trace Sink - TPIU
ROM 1 E0041000: CID B105900D PID 04002BB924 CoreSight dev ETM-M3 type 0x13 Trace Source - core
Cannot halt processor
Failed on chip setup: Ep(04). Cannot halt processor.

I'm pretty sure that the loaded project didn't block access to Flash memory in any way.

What can I do to program the MCU again?

Thanks in advance, best regards. 

Labels (1)
0 Kudos
1 Reply

341 Views
FelipeGarcia
NXP Employee
NXP Employee

Hello Marco,

 

What happens when you try to boot into ISP mode? Does it enters successfully into ISP mode?

 

Best regards,

Felipe

0 Kudos